Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-48053

Blue Ocean does not update status in Firefox Quantum

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Cannot Reproduce
    • blueocean-plugin
    • Blue Ocean 1.4 - beta 3

    Description

      Blue ocean and Firefox Quantum (don't know about earlier versions of FF) do not play well together. It seems as if the event source breaks as part of page loading. I see this error message in the dev console of FF:

      The connection to https://<url-redacted>.com:8443/sse-gateway/listen/jenkins-blueocean-core-js-1510819176806-8g0ww was interrupted while the page was loading.

      Not knowing much about the implementation of the UI I assume the above is what prevents the UI from updating the status. I have to resort to page reloads to get updates... or use Chrome ofc but I would much rather use Firefox.

      Attachments

        Issue Links

          Activity

            michaelneale Michael Neale added a comment -

            Gah, this is annoying. Edge, IE11, Chrome, Safari all work - but FF quantum breaks things yet again (it seems to be rubbish)

            michaelneale Michael Neale added a comment - Gah, this is annoying. Edge, IE11, Chrome, Safari all work - but FF quantum breaks things yet again (it seems to be rubbish)
            jamesdumay James Dumay added a comment -

            nicu I've added this one to your queue.

            jamesdumay James Dumay added a comment - nicu I've added this one to your queue.
            michaelneale Michael Neale added a comment -

            johnae we are having trouble reproducing it. That error message in the log seems to happen when the page is refreshed (either by clicking on the logo) but doesn't necessarily mean SSE isn't working (server sent events are how the updates are pushed in realtime to the brower). 

            Can you record possibly a video of things that show events not working, or things not updating when they should, or possibly steps to reproduce what you see? (there may be a specific breakage and that warning message is misleading...)

            michaelneale Michael Neale added a comment - johnae  we are having trouble reproducing it. That error message in the log seems to happen when the page is refreshed (either by clicking on the logo) but doesn't necessarily mean SSE isn't working (server sent events are how the updates are pushed in realtime to the brower).  Can you record possibly a video of things that show events not working, or things not updating when they should, or possibly steps to reproduce what you see? (there may be a specific breakage and that warning message is misleading...)
            johnae John Eriksson added a comment - - edited

            michaelneale While recording a video I discovered the cause of the problem. At first I was using the installation of jenkins where this manifests but later decided to set up a simpler installation for just this issue. Interestingly the problem didn't manifest there. The main difference was the Amazon Load Balancer in front of jenkins that we're using in production so I took a closer look at its configuration and discovered it had a relatively short idle timeout set (10 seconds). Increasing this to 60 seconds makes Firefox happy. It seems as if a ping is sent every 30 seconds or so from the blue ocean ui which may explain the behavior I've seen. It doesn't really explain why Chromium works fine but perhaps it deals with lost connections differently.

            I believe this issue can be closed. Sorry if I sent you on a wild-goose chase and thanks for your help!

            johnae John Eriksson added a comment - - edited michaelneale While recording a video I discovered the cause of the problem. At first I was using the installation of jenkins where this manifests but later decided to set up a simpler installation for just this issue. Interestingly the problem didn't manifest there. The main difference was the Amazon Load Balancer in front of jenkins that we're using in production so I took a closer look at its configuration and discovered it had a relatively short idle timeout set (10 seconds). Increasing this to 60 seconds makes Firefox happy. It seems as if a ping is sent every 30 seconds or so from the blue ocean ui which may explain the behavior I've seen. It doesn't really explain why Chromium works fine but perhaps it deals with lost connections differently. I believe this issue can be closed. Sorry if I sent you on a wild-goose chase and thanks for your help!
            michaelneale Michael Neale added a comment -

            johnae interesting - so perhaps it is more sensitive to timeouts and lost connections... perhaps we can close this for now and open it afresh if things aren't better with future versions of Quantum? 

            michaelneale Michael Neale added a comment - johnae interesting - so perhaps it is more sensitive to timeouts and lost connections... perhaps we can close this for now and open it afresh if things aren't better with future versions of Quantum? 
            johnae John Eriksson added a comment -

            Yeah I'm fine with closing this. At the very least this issue may help someone else experiencing this. Thanks again!

            johnae John Eriksson added a comment - Yeah I'm fine with closing this. At the very least this issue may help someone else experiencing this. Thanks again!
            kshultz Karl Shultz added a comment -

            Testing Notes:

            • It might be worthwhile to at least pursue what it would take to run our ATH in Firefox Quantum. I'll open an RFE for that.
            kshultz Karl Shultz added a comment - Testing Notes: It might be worthwhile to at least pursue what it would take to run our ATH in Firefox Quantum. I'll open an RFE for that.
            kshultz Karl Shultz added a comment -

            Link added to keep track of the RFE for more browser platforms in use with the ATH. Could well be underway already, but didn't see a ticket for it.

            kshultz Karl Shultz added a comment - Link added to keep track of the RFE for more browser platforms in use with the ATH. Could well be underway already, but didn't see a ticket for it.

            People

              nicu Nicolae Pascu
              johnae John Eriksson
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: