Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-481

ConcurrentModificationException during Maven build

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      started
      Reusing existing maven process
      FATAL: null
      java.util.ConcurrentModificationException
      at java.util.LinkedList$ListItr.checkForComodification(LinkedList.java:617)
      at java.util.LinkedList$ListItr.remove(LinkedList.java:585)
      at hudson.maven.ProcessCache.get(ProcessCache.java:144)
      at hudson.maven.MavenBuild$RunnerImpl.doRun(MavenBuild.java:252)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:121)
      at hudson.model.Run.run(Run.java:559)
      at hudson.maven.MavenBuild.run(MavenBuild.java:124)
      at hudson.model.Executor.run(Executor.java:61)

        Attachments

          Issue Links

            Activity

            kohsuke Kohsuke Kawaguchi added a comment -

            I discovered this independently and this is fixed for 1.103.

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 493 has been marked as a duplicate of this issue. ***

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              troggan troggan
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: