Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-48270

Machine environment variables not passed to pipeline

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      If I run a pipline that contains:

       

      node('some-machine') {
        checkout scm
        sh(script 'env')
      }

       

      I expect the checkout scm and the script to be passed the environment variables I defined in the machine configuration (Node properties > Environment variables in http://hostname/jenkins/computer/some-machine/configure), as that is passed to the Git Plugin and non-pipeline jobs. Not having this causes problems on some machines (in my case I can't run git through the pipeline)

       

        Attachments

          Issue Links

            Activity

            gibfahn Gibson Fahnestock created issue -
            abayer Andrew Bayer added a comment -

            Looks to be a dupe of JENKINS-44465.

            abayer Andrew Bayer made changes -
            Field Original Value New Value
            Link This issue duplicates JENKINS-44465 [ JENKINS-44465 ]
            abayer Andrew Bayer made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              gibfahn Gibson Fahnestock
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: