Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-48567

vSphere plugin crashes global configuration of jenkins

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      After upgrading from jenkins 2.73.3 to 2.89.2, the configuration screen 'jenkins/configure' load fails when drawing 'template' select box from plugin.

      When vsphere-cloud-plugin is removed then everything works fine.

        Attachments

          Activity

          leandrofranca Leandro França created issue -
          wreggyl Jan Bottek made changes -
          Field Original Value New Value
          Attachment stacktrace_create_new_cloud_on_jenkins_2_89_1.txt [ 40707 ]
          wreggyl Jan Bottek made changes -
          wreggyl Jan Bottek added a comment -

          this problem also occur if you install the plugin on a new Jenkins => trying to add a new Vspere clouds results in a exception ( see attachment ). On an upgraded Jenkins, where the plugin is already installed, we have the same hanging configuration. 

          stacktrace_create_new_cloud_on_jenkins_2_89_1.txt

          stacktrace_upgrade_to_2_89_1_with_vsphere_cloud_configured.txt

          wreggyl Jan Bottek added a comment -

          maybe it belongs to the same issue which the EC2 plugin has?

           
          Two potential problems have been identified with this change:

          • Jenkins does not automatically install the plugin when upgrading from before Jenkins 2.86 to that version or newer. This includes an upgrade to 2.89.1 from any earlier LTS release. The plugin will need to be installed manually after an update. If it appears to be unavailable on the update center, make sure to update the cached metadata by clicking Check Now.
          • The integration with Script Security can result in problems with plugins making use of this launch method internally in a way that is incompatible with the security model of Script Security. A known instance of this problem is EC2 Plugin. The issue is tracked as JENKINS-47593.
          leandrofranca Leandro França added a comment -

          You are right. After reinstalled the plugin manually the problem was solved!

          Thanks Jan Bottek.

          leandrofranca Leandro França made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          leandrofranca Leandro França added a comment -

          Should I resolve this issue or leave it open?

          wreggyl Jan Bottek added a comment -

          please leave it open, because i do not understand what you did that the issue is solved

          i tested the installation on a clean jenkins and was not able to add a Vsphere Cloud. I tested it on an upgrade and got the hanging configuration.

          So what ever I wrote helped you to fix it - please help me to understand

          leandrofranca Leandro França added a comment -

          I just disabled the vSphere plugin (without uninstall), then downloaded hpi again and I've installed it manually. After restart everything works.

          wreggyl Jan Bottek added a comment -

          did you had to add the configuration for the vsphere cloud again or was is it still there ( because you didn't uninstalled it)? is the launching for the jenkins agent working?

          leandrofranca Leandro França added a comment -

          Yes, I needed to add the configuration again (it was empty after deactivation). I did not uninstall it to avoid losing dependencies. I can't test "Slave virtual computer running under vSphere Cloud" still.

          danielbeck Daniel Beck added a comment -

          This is caused by the core bug that does not install command-launcher plugin even though it should, resulting in ClassNotFoundError.

          Will be fixed towards 2.89.3, is already fixed in the weeklies.

          danielbeck Daniel Beck made changes -
          Resolution Duplicate [ 3 ]
          Status In Progress [ 3 ] Resolved [ 5 ]

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            leandrofranca Leandro França
            Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: