Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-49008

java.nio.file.AccessDeniedException: /var/lib/jenkins/config.xml

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: other
    • Labels:
      None
    • Similar Issues:

      Description

      I have installed jenkins as a standalone application on my linux machine.

      It was working fine until I stopped and started Jenkins service and since then I am getting this error. I have also given full permission to config.xml but even then I am unable to view my home page for jenkins.

       

        Attachments

          Activity

          oleg_nenashev Oleg Nenashev added a comment -

          Under which account do you run Jenkins?

          shrawani shrawani karpe added a comment -

          under the same account that I created when I first installed Jenkins. i.e. "shrawani"

          oleg_nenashev Oleg Nenashev added a comment -

          /var/lib/jenkins definitely points to Jenkins packaging (deb/RPM). These packages use "jenkins" account by default, not a user account one.

          I think that the issue is valid, you're likely just trying to use JENKINS_HOME from another account which has no permissions to /var/lib

          oleg_nenashev Oleg Nenashev added a comment -

          No response from the reporter. Closing as "Not a defect"


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            shrawani shrawani karpe
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: