Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-49231

jira-plugin 2.5.1 throws exception fails build

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: jira-plugin
    • Environment:
      Jenkins 2.89.2
      JIRA plugin 2.5.1
      P4 plugin 1.8.4

      Atlassian JIRA v7.3.6
    • Similar Issues:

      Description

      Since upgrading JIRA plugin 2.5 --> 2.5.1 builds fail with exception below.  No pipeline steps are invoked.  Reverting to version 2.5 resolves the issue.  The jobs are defined in declarative Jenkinsfiles and sources are pulled from Perforce

      java.lang.LinkageError: loader constraint violation: when resolving field "BROWSER_COMPATIBLE_HOSTNAME_VERIFIER" the class loader (instance of hudson/ClassicPluginStrategy$AntClassLoader2) of the referring class, org/apache/http/nio/conn/ssl/SSLIOSessionStrategy, and the class loader (instance of hudson/ClassicPluginStrategy$AntClassLoader2) for the field's resolved type, org/apache/http/conn/ssl/X509HostnameVerifier, have different Class objects for that type
      	at com.atlassian.httpclient.apache.httpcomponents.ApacheAsyncHttpClient.getRegistry(ApacheAsyncHttpClient.java:267)
      	at com.atlassian.httpclient.apache.httpcomponents.ApacheAsyncHttpClient.<init>(ApacheAsyncHttpClient.java:178)
      	at com.atlassian.httpclient.apache.httpcomponents.ApacheAsyncHttpClient.<init>(ApacheAsyncHttpClient.java:123)
      	at com.atlassian.httpclient.apache.httpcomponents.DefaultHttpClientFactory.doCreate(DefaultHttpClientFactory.java:68)
      	at com.atlassian.httpclient.apache.httpcomponents.DefaultHttpClientFactory.create(DefaultHttpClientFactory.java:35)
      	at com.atlassian.jira.rest.client.internal.async.AsynchronousHttpClientFactory.createClient(AsynchronousHttpClientFactory.java:63)
      	at com.atlassian.jira.rest.client.internal.async.AsynchronousJiraRestClientFactory.create(AsynchronousJiraRestClientFactory.java:35)
      	at com.atlassian.jira.rest.client.internal.async.AsynchronousJiraRestClientFactory.createWithBasicHttpAuthentication(AsynchronousJiraRestClientFactory.java:42)
      	at hudson.plugins.jira.JiraSite.createSession(JiraSite.java:303)
      	at hudson.plugins.jira.JiraSite.getSession(JiraSite.java:278)
      	at hudson.plugins.jira.JiraMailAddressResolver.findMailAddressFor(JiraMailAddressResolver.java:37)
      	at hudson.tasks.MailAddressResolver.resolve(MailAddressResolver.java:122)
      	at hudson.tasks.Mailer$UserProperty.getAddress(Mailer.java:614)
      	at org.jenkinsci.plugins.p4.changes.P4ChangeEntry.setChange(P4ChangeEntry.java:87)
      	at org.jenkinsci.plugins.p4.changes.P4ChangeRef.getChangeEntry(P4ChangeRef.java:20)
      	at org.jenkinsci.plugins.p4.tasks.CheckoutTask.getChangesFull(CheckoutTask.java:287)
      	at org.jenkinsci.plugins.p4.PerforceScm.calculateChanges(PerforceScm.java:520)
      	at org.jenkinsci.plugins.p4.PerforceScm.checkout(PerforceScm.java:482)
      	at org.jenkinsci.plugins.workflow.steps.scm.SCMStep.checkout(SCMStep.java:113)
      	at org.jenkinsci.plugins.workflow.cps.CpsScmFlowDefinition.create(CpsScmFlowDefinition.java:138)
      	at org.jenkinsci.plugins.workflow.cps.CpsScmFlowDefinition.create(CpsScmFlowDefinition.java:64)
      	at org.jenkinsci.plugins.workflow.job.WorkflowRun.run(WorkflowRun.java:271)
      	at hudson.model.ResourceController.execute(ResourceController.java:97)
      	at hudson.model.Executor.run(Executor.java:421)
      Finished: FAILURE

        Attachments

          Issue Links

            Activity

            oleg_nenashev Oleg Nenashev added a comment -

            Caused by partial fix of JENKINS-48357

            warden Radek Antoniuk added a comment -

            I'm closing this duplicate as 2.5.1 has been blacklisted due to JENKINS-48357, please revert to 2.5 and wait for original cause fix by watching JENKINS-48357.


              People

              Assignee:
              olamy Olivier Lamy
              Reporter:
              simon_watts Simon Watts
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: