Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5023

Discard old build doesn't work anymore in 1.336

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Blocker
    • Resolution: Fixed
    • core
    • None

    Description

      since my upgrade to 1.336 old builds are not anymore cleaned. (using "Max # of builds to keep" to 20)

      Attachments

        Activity

          olamy Olivier Lamy added a comment -

          in fact it's due to JENKINS-5022.

          olamy Olivier Lamy added a comment - in fact it's due to JENKINS-5022 .
          olamy Olivier Lamy added a comment -

          searching in log (I don't know if it's linked), I found :

          Caused by: java.lang.NullPointerException
                  at java.lang.String.compareTo(String.java:1176)
                  at hudson.model.Job$2.compare(Job.java:432)
                  at hudson.model.Job$2.compare(Job.java:426)
                  at hudson.widgets.HistoryWidget.doAjax(HistoryWidget.java:163)
                  at sun.reflect.GeneratedMethodAccessor150.invoke(Unknown Source)
                  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
                  at java.lang.reflect.Method.invoke(Method.java:613)
                  at org.kohsuke.stapler.Function$InstanceFunction.invoke(Function.java:185)
                  at org.kohsuke.stapler.Function.bindAndInvoke(Function.java:101)
                  at org.kohsuke.stapler.Function.bindAndInvokeAndServeResponse(Function.java:54)
                  at org.kohsuke.stapler.MetaClass$1.doDispatch(MetaClass.java:74)
                  at org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
                  at org.kohsuke.stapler.Stapler.invoke(Stapler.java:492)
                  ... 52 more
          
          olamy Olivier Lamy added a comment - searching in log (I don't know if it's linked), I found : Caused by: java.lang.NullPointerException at java.lang. String .compareTo( String .java:1176) at hudson.model.Job$2.compare(Job.java:432) at hudson.model.Job$2.compare(Job.java:426) at hudson.widgets.HistoryWidget.doAjax(HistoryWidget.java:163) at sun.reflect.GeneratedMethodAccessor150.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:613) at org.kohsuke.stapler.Function$InstanceFunction.invoke(Function.java:185) at org.kohsuke.stapler.Function.bindAndInvoke(Function.java:101) at org.kohsuke.stapler.Function.bindAndInvokeAndServeResponse(Function.java:54) at org.kohsuke.stapler.MetaClass$1.doDispatch(MetaClass.java:74) at org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30) at org.kohsuke.stapler.Stapler.invoke(Stapler.java:492) ... 52 more
          olamy Olivier Lamy added a comment -

          attached a patch which will skip error on a publisher and will continue execute the others.

          olamy Olivier Lamy added a comment - attached a patch which will skip error on a publisher and will continue execute the others.

          Code changed in hudson
          User: : abayer
          Path:
          trunk/hudson/main/core/src/main/java/hudson/model/AbstractBuild.java
          trunk/www/changelog.html
          http://fisheye4.cenqua.com/changelog/hudson/?cs=24433
          Log:
          [FIXED JENKINS-5023] Subsequent publishers should still run even if an earlier publisher throws an exception

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : abayer Path: trunk/hudson/main/core/src/main/java/hudson/model/AbstractBuild.java trunk/www/changelog.html http://fisheye4.cenqua.com/changelog/hudson/?cs=24433 Log: [FIXED JENKINS-5023] Subsequent publishers should still run even if an earlier publisher throws an exception

          Code changed in hudson
          User: : mindless
          Path:
          trunk/hudson/main/core/src/main/java/hudson/model/AbstractBuild.java
          http://fisheye4.cenqua.com/changelog/hudson/?cs=24459
          Log:
          JENKINS-5023 be more verbose.. write full exception detail in both job console and java Logger,
          instead of just writing just e.getMessage() to Logger.

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : mindless Path: trunk/hudson/main/core/src/main/java/hudson/model/AbstractBuild.java http://fisheye4.cenqua.com/changelog/hudson/?cs=24459 Log: JENKINS-5023 be more verbose.. write full exception detail in both job console and java Logger, instead of just writing just e.getMessage() to Logger.

          People

            abayer Andrew Bayer
            olamy Olivier Lamy
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: