Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5051

NoClassDefFoundError: hudson/plugins/tasks/util/model/Priority

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: tasks-plugin
    • Labels:
      None
    • Environment:
      Hudson 1.330, task plugin 4.0, analysis plugin 1.0, Master on Windows Server 2003 R2.
    • Similar Issues:

      Description

      I found the following exception in hudson.err.log:

      9-dic-2009 12.33.01 hudson.model.Run run
      INFO: Foundation #9 main build action completed: SUCCESS
      9-dic-2009 12.33.03 hudson.plugins.analysis.core.BuildResult loadResult
      INFO: Loaded data file C:\DeveloperTools\Hudson\jobs\Foundation\builds\2009-12-04_10-22-28\open-tasks.xml for build 7
      9-dic-2009 12.33.05 hudson.plugins.analysis.core.BuildResult loadResult
      INFO: Loaded data file C:\DeveloperTools\Hudson\jobs\Foundation\builds\2009-12-04_10-22-28\compiler-warnings.xml for build 7
      9-dic-2009 12.33.07 hudson.model.Executor run
      GRAVE: Executor throw an exception unexpectedly
      java.lang.NoClassDefFoundError: hudson/plugins/tasks/util/model/Priority
      at hudson.plugins.cigame.rules.plugins.opentasks.OpenTasksRuleSet.loadRules(OpenTasksRuleSet.java:14)
      at hudson.plugins.cigame.rules.plugins.PluginRuleSet.getRules(PluginRuleSet.java:48)
      at hudson.plugins.cigame.model.ScoreCard.record(ScoreCard.java:33)
      at hudson.plugins.cigame.model.ScoreCard.record(ScoreCard.java:54)
      at hudson.plugins.cigame.GamePublisher.perform(GamePublisher.java:56)
      at hudson.plugins.cigame.GamePublisher.perform(GamePublisher.java:42)
      at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36)
      at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:508)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:494)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:482)
      at hudson.model.Build$RunnerImpl.cleanUp(Build.java:187)
      at hudson.model.Run.run(Run.java:1216)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:123)
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.tasks.util.model.Priority
      at java.net.URLClassLoader$1.run(Unknown Source)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at java.lang.ClassLoader.loadClassInternal(Unknown Source)
      ... 15 more

        Attachments

          Issue Links

            Activity

            olamy Olivier Lamy added a comment -

            please have a look at JENKINS-5022 and try the patch

            drulli Ulli Hafner added a comment -

              People

              Assignee:
              drulli Ulli Hafner
              Reporter:
              mambu Marco Ambu
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: