Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-514

disabling plugin can cause jobs to disappear

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: plugin-proposals
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Created three jobs and enabled the Trac plugin for them. Upon
      disabling the Trac plugin (or removing it) and restarting Hudson,
      all three jobs disappear. After re-enabling the plugin, the jobs
      are back.

        Attachments

          Activity

          bradfritz bradfritz added a comment -

          As Kohsuke suggested[1], the problem is with XStream
          trying to read the jobs' config.xml files. Specifically,
          the problem is an XStream CannotResolveClassException
          for hudson.plugins.trac.TracRepositoryBrowser.

          I suspect RobustCollectionConverter is not being used
          because TracRepositoryBrowser is in a "browser" element
          that is not part of a Collection. I have not traced
          through the XStream Converter selection to say for sure
          though.

          I will attach a sample config.xml and a stack trace.

          --Brad

          [1] http://www.nabble.com/jobs-disappear-after-disabling-Trac-plugin-tf3649227.html

          bradfritz bradfritz added a comment -

          Created an attachment (id=58)
          Job config.xml file (very slightly obfuscated...just URLs and email addresses).

          bradfritz bradfritz added a comment -

          Created an attachment (id=59)
          stack trace showing XStream ConversionException for TracRepositoryBrowser

          kohsuke Kohsuke Kawaguchi added a comment -

          Ah, that explains. The RobustCollectionConverter only kicks in for collections.

          I'll check if this issue is fixed in XStream, and if not, time to patch XStream...

          kohsuke Kohsuke Kawaguchi added a comment -

          Fixed in 1.105.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            bradfritz bradfritz
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: