Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-51849

Plugins install fails due to java.net.SocketTimeoutException: Read timed out error

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Jenkins version 2.89.4, Linux
    • Similar Issues:
    • Sprint:
      Post-launch

      Description

      I am getting below java.net.SocketTimeoutException: Read timed out error while installing/updating the plugins in all of my jenkins (8-10 Jenkins master version 2.89.4 && 2.73.3)

      Installing Plugins/Upgrades
      Preparation
      Checking internet connectivity
      Checking update center connectivity
      Success
      Static Analysis Utilities analysis-core plugin is already installed. Jenkins needs to be restarted for the update to take effect
      CCM
      Failure - Details
      CCM
      Failure - Details
      Folders Downloaded Successfully. Will be activated during the next boot
      Git client
      Failure -
      java.net.SocketTimeoutException: Read timed out
      at java.net.SocketInputStream.socketRead0(Native Method)
      at java.net.SocketInputStream.socketRead(SocketInputStream.java:116)
      at java.net.SocketInputStream.read(SocketInputStream.java:171)
      at java.net.SocketInputStream.read(SocketInputStream.java:141)
      at java.io.BufferedInputStream.read1(BufferedInputStream.java:284)
      at java.io.BufferedInputStream.read(BufferedInputStream.java:345)
      at sun.net.www.MeteredStream.read(MeteredStream.java:134)
      at java.io.FilterInputStream.read(FilterInputStream.java:133)
      at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(HttpURLConnection.java:3393)
      at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(HttpURLConnection.java:3386)
      at org.apache.commons.io.input.ProxyInputStream.read(ProxyInputStream.java:77)
      at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:1141)
      Caused: java.io.IOException: Failed to load http://updates.jenkins-ci.org/download/plugins/git-client/2.7.1/git-client.hpi to /app/jenkins/taaa-build/plugins/git-client.jpi.tmp
      at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:1146)
      Caused: hudson.util.IOException2: Failed to download from http://updates.jenkins-ci.org/download/plugins/git-client/2.7.1/git-client.hpi
      at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:1172)
      at hudson.model.UpdateCenter$DownloadJob._run(UpdateCenter.java:1677)
      at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1874)
      at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1651)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
      at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:110)
      at java.lang.Thread.run(Thread.java:748)
      Git Downloaded Successfully. Will be activated during the next boot
      SCM API Downloaded Successfully. Will be activated during the next boot
      Branch API
      Failure -
      java.net.SocketTimeoutException: Read timed out
      at java.net.SocketInputStream.socketRead0(Native Method)
      at java.net.SocketInputStream.socketRead(SocketInputStream.java:116)
      at java.net.SocketInputStream.read(SocketInputStream.java:171)
      at java.net.SocketInputStream.read(SocketInputStream.java:141)
      at java.io.BufferedInputStream.read1(BufferedInputStream.java:284)
      at java.io.BufferedInputStream.read(BufferedInputStream.java:345)
      at sun.net.www.MeteredStream.read(MeteredStream.java:134)
      at java.io.FilterInputStream.read(FilterInputStream.java:133)
      at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(HttpURLConnection.java:3393)
      at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(HttpURLConnection.java:3386)
      at org.apache.commons.io.input.ProxyInputStream.read(ProxyInputStream.java:77)
      at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:1141)
      Caused: java.io.IOException: Failed to load http://updates.jenkins-ci.org/download/plugins/branch-api/2.0.19/branch-api.hpi to /app/jenkins/taaa-build/plugins/branch-api.jpi.tmp
      at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:1146)
      Caused: hudson.util.IOException2: Failed to download from http://updates.jenkins-ci.org/download/plugins/branch-api/2.0.19/branch-api.hpi
      at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:1172)
      at hudson.model.UpdateCenter$DownloadJob._run(UpdateCenter.java:1677)
      at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1874)
      at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1651)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
      at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:110)
      at java.lang.Thread.run(Thread.java:748)

       

      I have tried to install couple of new jenkins and I am still not able to install the suggested plugins, not all but most of the plugins are failing to install with the same above error.

       

      My server logs are shown below 

      Caused by: java.io.IOException: Failed to load http://updates.jenkins-ci.org/download/plugins/analysis-core/1.95/analysis-core.hpi to /app/jenkins/tabt-cd-deploy/plugins/analysis-core.jpi.tmp
      at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:1146)
      ... 7 more
      Caused by: java.net.SocketTimeoutException: Read timed out
      at java.net.SocketInputStream.socketRead0(Native Method)
      at java.net.SocketInputStream.socketRead(SocketInputStream.java:116)
      at java.net.SocketInputStream.read(SocketInputStream.java:171)
      at java.net.SocketInputStream.read(SocketInputStream.java:141)
      at java.io.BufferedInputStream.read1(BufferedInputStream.java:284)
      at java.io.BufferedInputStream.read(BufferedInputStream.java:345)
      at sun.net.www.MeteredStream.read(MeteredStream.java:134)
      at java.io.FilterInputStream.read(FilterInputStream.java:133)
      at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(HttpURLConnection.java:3375)
      at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(HttpURLConnection.java:3368)
      at org.apache.commons.io.input.ProxyInputStream.read(ProxyInputStream.java:77)
      at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:1141)
      ... 7 more

      10-Jun-2018 16:06:22.736 INFO Update center installer thread [#4] hudson.model.UpdateCenter$DownloadJob.run Starting the installation of CCM on behalf of admin
      10-Jun-2018 16:06:22.752 INFO Update center installer thread [#4] hudson.model.UpdateCenter$UpdateCenterConfiguration.download Downloading CCM
      10-Jun-2018 16:07:22.802 SEVERE Update center installer thread [#4] hudson.model.UpdateCenter$DownloadJob.run Failed to install CCM
      hudson.util.IOException2: Failed to download from http://updates.jenkins-ci.org/download/plugins/ccm/3.2/ccm.hpi
      at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:1172)
      at hudson.model.UpdateCenter$DownloadJob._run(UpdateCenter.java:1677)
      at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1874)
      at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1651)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
      at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:110)
      at java.lang.Thread.run(Thread.java:748)
      Caused by: java.io.IOException: Failed to load http://updates.jenkins-ci.org/download/plugins/ccm/3.2/ccm.hpi to /app/jenkins/tabt-cd-deploy/plugins/ccm.jpi.tmp
      at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:1146)
      ... 7 more
      Caused by: java.net.SocketTimeoutException: Read timed out
      at java.net.SocketInputStream.socketRead0(Native Method)
      at java.net.SocketInputStream.socketRead(SocketInputStream.java:116)
      at java.net.SocketInputStream.read(SocketInputStream.java:171)
      at java.net.SocketInputStream.read(SocketInputStream.java:141)
      at java.io.BufferedInputStream.read1(BufferedInputStream.java:284)
      at java.io.BufferedInputStream.read(BufferedInputStream.java:345)
      at sun.net.www.MeteredStream.read(MeteredStream.java:134)
      at java.io.FilterInputStream.read(FilterInputStream.java:133)
      at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(HttpURLConnection.java:3375)
      at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(HttpURLConnection.java:3368)
      at org.apache.commons.io.input.ProxyInputStream.read(ProxyInputStream.java:77)
      at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:1141)
      ... 7 more

      10-Jun-2018 22:00:06.285 INFO [Workspace clean-up thread] hudson.model.AsyncPeriodicWork$1.run Started Workspace clean-up
      10-Jun-2018 22:00:06.286 INFO [Workspace clean-up thread] hudson.model.AsyncPeriodicWork$1.run Finished Workspace clean-up. 1 ms

        Attachments

          Issue Links

            Activity

            mcascone Max Cascone added a comment -

            we are getting the same problem in USA:

            java.net.SocketTimeoutException: Read timed out
            	at java.net.SocketInputStream.socketRead0(Native Method)
            	at java.net.SocketInputStream.socketRead(SocketInputStream.java:116)
            	at java.net.SocketInputStream.read(SocketInputStream.java:171)
            	at java.net.SocketInputStream.read(SocketInputStream.java:141)
            	at sun.security.ssl.InputRecord.readFully(InputRecord.java:465)
            	at sun.security.ssl.InputRecord.read(InputRecord.java:503)
            	at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:990)
            	at sun.security.ssl.SSLSocketImpl.readDataRecord(SSLSocketImpl.java:948)
            	at sun.security.ssl.AppInputStream.read(AppInputStream.java:105)
            	at java.io.BufferedInputStream.fill(BufferedInputStream.java:246)
            	at java.io.BufferedInputStream.read1(BufferedInputStream.java:286)
            	at java.io.BufferedInputStream.read(BufferedInputStream.java:345)
            	at sun.net.www.http.HttpClient.parseHTTPHeader(HttpClient.java:735)
            	at sun.net.www.http.HttpClient.parseHTTP(HttpClient.java:678)
            	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1593)
            	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1498)
            	at sun.net.www.protocol.http.HttpURLConnection.getHeaderField(HttpURLConnection.java:3061)
            	at java.net.URLConnection.getHeaderFieldLong(URLConnection.java:629)
            	at java.net.URLConnection.getContentLengthLong(URLConnection.java:501)
            	at java.net.URLConnection.getContentLength(URLConnection.java:485)
            	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getContentLength(HttpsURLConnectionImpl.java:412)
            	at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:1264)
            Caused: java.net.SocketTimeoutException: Read timed out
            	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
            	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
            	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
            	at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
            	at sun.net.www.protocol.http.HttpURLConnection$10.run(HttpURLConnection.java:1950)
            	at sun.net.www.protocol.http.HttpURLConnection$10.run(HttpURLConnection.java:1945)
            	at java.security.AccessController.doPrivileged(Native Method)
            	at sun.net.www.protocol.http.HttpURLConnection.getChainedException(HttpURLConnection.java:1944)
            	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1514)
            	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1498)
            	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:268)
            	at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:1280)
            Caused: java.io.IOException: Failed to load https://updates.jenkins.io/download/plugins/custom-checkbox-parameter/1.1/custom-checkbox-parameter.hpi to /mnt/data/jenkins/plugins/custom-checkbox-parameter.jpi.tmp
            	at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:1287)
            Caused: java.io.IOException: Failed to download from https://updates.jenkins.io/download/plugins/custom-checkbox-parameter/1.1/custom-checkbox-parameter.hpi (redirected to: https://get.jenkins.io/plugins/custom-checkbox-parameter/1.1/custom-checkbox-parameter.hpi)
            	at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:1321)
            	at hudson.model.UpdateCenter$DownloadJob._run(UpdateCenter.java:1869)
            	at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:2147)
            	at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1843)
            	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
            	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
            	at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:118)
            	at java.lang.Thread.run(Thread.java:748) 
            chgannett chuck h added a comment - - edited

            Same problem as others have mentioned.  Began about 24 hours ago (from timestamp of this message)

            thiagolmoraes Thiago Moraes added a comment -

            Same Problem here in BR. I'm since 2 day ago trying to install some plugins!

            markewaite Mark Waite added a comment - - edited

            If you need to download a plugin and all of its dependencies, use the following series of commands as an example:

            $ export GITHUB=https://github.com/jenkinsci/plugin-installation-manager-tool/releases
            $ wget $GITHUB/download/2.1.1/jenkins-plugin-manager-2.1.1.jar
            $ export JENKINS_UC_DOWNLOAD=https://mirror.xmission.com/jenkins/ # Your mirror here
            $ java -jar jenkins-plugin-manager-2.1.1.jar --verbose --plugins blueocean:1.24.3 # your plugins here
            

            Docker workaround

            The Jenkins Docker image includes the jenkins-plugin-cli script that calls the Jenkins plugin installation manager tool. The plugin installation manager is now used in the Jenkins install guide for Docker and in the Jenkins build tools tutorials.

            markewaite Mark Waite added a comment -

            Follow the duplicate INFRA-2811


              People

              Assignee:
              abubakar22 Abubakar Mohammed
              Reporter:
              abubakar22 Abubakar Mohammed
              Votes:
              5 Vote for this issue
              Watchers:
              17 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: