Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52085

Jobs in queue are not sorted

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Not A Defect
    • Component/s: prioritysorter-plugin
    • Labels:
      None
    • Environment:
      Ubuntu 16.04.4
      openjdk 8u171-b11
      Jenkins 2.107.3
      Priority Sorter Plugin 3.6.0
    • Similar Issues:

      Description

      Priority Configuration (refer to Selection_010.png):
      Strategy: Absolute
      Number of Priorities: 10
      Default Priority: 10
      Only Admins can edit Job Priorities: selected

      Priority Job Group Configuration (refer to Selection_011.png and Selection_012.png):
      Jobs to include: Jobs and Folders marked for inclusion
      Job Group Name: Priority2
      Priority: 2
      Jobs to include: Jobs and Folders marked for inclusion
      Job Group Name: Priority5
      Priority: 5

      Jenkins freestyle Job1:
      Name: Priority5
      Input String parameter name: trigger
      Include this job in a job group: Priority5
      Build Step: sleep 600

      Jenkins freestyle Job2:
      Name: Priority2
      Input String parameter name: trigger
      Include this job in a job group: Priority2
      Build Step: sleep 600

      Steps to reproduce:
      1. trigger Job1 (Priority5) with trigger=1
      2. trigger Job2 (Priority2) with trigger=2
      (so both jobs are running with sleep 600 seconds)

      3. trigger Job1 (Priority5) with trigger=3
      4. trigger Job2 (Priority2) with trigger=4
      5. trigger Job1 (Priority5) with trigger=5
      6. trigger Job2 (Priority2) with trigger=6
      7. trigger Job1 (Priority5) with trigger=7
      8. trigger Job2 (Priority2) with trigger=8
      9. trigger Job1 (Priority5) with trigger=9
      10. trigger Job2 (Priority2) with trigger=10
      (these jobs are waiting in the queue)

      Expected results from queue:
      the jobs in the queu should be sorted into 2 groups,
      where Job2 (Priority2) goes first and Job1 (Priority5) goes behind.

      But the actual results from the queue (refer to Selection_009.png):
      The jobs are sorted acoording to the time when the job was triggered.
      (the same order sequence as how the job is triggered)

        Attachments

        1. Selection_009.png
          Selection_009.png
          5 kB
        2. Selection_010.png
          Selection_010.png
          28 kB
        3. Selection_011.png
          Selection_011.png
          18 kB
        4. Selection_012.png
          Selection_012.png
          17 kB

          Activity

          totoroliu Rick Liu added a comment -

          the behavior in queue is caused by not enabling concurrent build.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            totoroliu Rick Liu
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: