Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52414

Current builds occasionally disappear from view in build history sidebar until refresh

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Component/s: core
    • Labels:
    • Environment:
      Jenkins Version 2.121.1
    • Similar Issues:

      Description

      This seems purely cosmetic, but annoying nonetheless. Occasionally when viewing a job page, one or more of the currently building jobs will disappear from the build history sidebar. A refresh of the page will usually bring them back, though not for very long.

      I think this differs from all the other "builds disappearing from build history" tickets in that a browser refresh shows them again (at least temporarily) and it's only when the build is occurring (blinking ball with progress bar); no completed builds have been observed as disappearing.

      This has been observed on the latest versions of Chrome on Windows and Mac, and Safari on Mac.

        Attachments

        1. build.xml
          7 kB
        2. config.xml
          20 kB

          Activity

          Hide
          oleg_nenashev Oleg Nenashev added a comment -

          Thanks for reporting it! Could you please provide the job type and, if possible, the Job's config.xml and build.xml for the missing build?

          Show
          oleg_nenashev Oleg Nenashev added a comment - Thanks for reporting it! Could you please provide the job type and, if possible, the Job's config.xml and build.xml for the missing build?
          Hide
          rothwerx Jeremiah Roth added a comment -

          We pretty much only use freestyle jobs, and I've seen it occur on many of them. But included is the config.xml and build.xml for one in which it was observed (note the buildsByBranchName entries of the build.xml was snipped). build.xml

          Show
          rothwerx Jeremiah Roth added a comment - We pretty much only use freestyle jobs, and I've seen it occur on many of them. But included is the config.xml and build.xml for one in which it was observed (note the buildsByBranchName entries of the build.xml was snipped).  build.xml

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            rothwerx Jeremiah Roth
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated: