Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52448

Requirements for Powershell DSL are unclear.

    XMLWordPrintable

Details

    Description

      Hi there, I have a very basic Jenkinsfile (attached) which I am attempting to run. Every time I run the pipeline however, I get the error below from Java (error attached). I assume that this is because the correct plugins and/or versions of said plugins aren't installed on my Jenkins server. However, I am finding it difficult to ascertain a complete list of required plugins.

      Would it be possible to have one provided?

      If I am going wrong anywhere, please let me know!

      Thank you!

      Niall.

       

      Attachments

        1. Error.rtf
          4 kB
        2. Jenkinsfile
          0.5 kB

        Activity

          nialljudedev Niall Collins created issue -
          duemir Denys Digtiar made changes -
          Field Original Value New Value
          Component/s durable-task-plugin [ 18622 ]
          Component/s powershell-plugin [ 16044 ]
          duemir Denys Digtiar added a comment -

          There is a typo in the Pipeline. The step names are case sensitive. There is not powerShell step only powershell.

          duemir Denys Digtiar added a comment - There is a typo in the Pipeline. The step names are case sensitive. There is not powerShell step only powershell .
          duemir Denys Digtiar made changes -
          Resolution Not A Defect [ 7 ]
          Status Open [ 1 ] Resolved [ 5 ]

          People

            Unassigned Unassigned
            nialljudedev Niall Collins
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: