Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-534

"java.lang.NumberFormatException: null" when saving a module

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: Macintosh, OS: Mac OS X
    • Similar Issues:

      Description

      When trying to edit a module generated off a project pom, the following error
      results not matter what information is entered and saved:

      javax.servlet.ServletException: null
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:279)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:361)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:240)
      org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:207)
      org.kohsuke.stapler.Stapler.service(Stapler.java:72)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

      root cause

      java.lang.NumberFormatException: null
      java.lang.Integer.parseInt(Integer.java:415)
      java.lang.Integer.parseInt(Integer.java:497)
      hudson.scm.SCMS.parseSCM(SCMS.java:30)
      hudson.model.AbstractProject.submit(AbstractProject.java:548)
      hudson.maven.MavenModule.submit(MavenModule.java:255)
      hudson.model.Job.doConfigSubmit(Job.java:510)
      sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      java.lang.reflect.Method.invoke(Method.java:585)
      org.kohsuke.stapler.Function$InstanceFunction.invoke(Function.java:95)
      org.kohsuke.stapler.Function.bindAndinvoke(Function.java:51)
      org.kohsuke.stapler.MetaClass$1.doDispatch(MetaClass.java:63)
      org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:361)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:240)
      org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:207)
      org.kohsuke.stapler.Stapler.service(Stapler.java:72)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

        Attachments

          Issue Links

            Activity

            kohsuke Kohsuke Kawaguchi added a comment -

            Ouch! Fixed in 1.106.

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 551 has been marked as a duplicate of this issue. ***

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              jcblitz jcblitz
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: