Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5383

1.342 failed to start with NoSuchFieldError: DESCRIPTOR

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • core, sectioned-view-plugin
    • None
    • SunOS build 5.10 Generic_118833-36 sun4u sparc SUNW,Sun-Fire-V240
      HUdson 'home' located on NFS server.

    Description

      SEVERE: Failed Loading global config
      hudson.util.IOException2: Unable to read /data/hudson-build/.hudson/config.xml
              at hudson.XmlFile.unmarshal(XmlFile.java:154)
              at hudson.model.Hudson$11.run(Hudson.java:2095)
              at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
              at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
              at hudson.model.Hudson$3.runTask(Hudson.java:648)
              at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
              at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
              at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
              at java.lang.Thread.run(Thread.java:595)
      Caused by: java.lang.NoSuchFieldError: DESCRIPTOR
              at hudson.plugins.sectioned_view.ListViewSection.<clinit>(ListViewSection.java:37)
              at sun.reflect.GeneratedSerializationConstructorAccessor27.newInstance(Unknown Source)
              at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
              at com.thoughtworks.xstream.converters.reflection.Sun14ReflectionProvider.newInstance(Sun14ReflectionProvider.java:76)
              at hudson.util.RobustReflectionConverter.instantiateNewInstance(RobustReflectionConverter.java:302)
              at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:171)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
              at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
              at com.thoughtworks.xstream.converters.collections.AbstractCollectionConverter.readItem(AbstractCollectionConverter.java:71)
              at hudson.util.CopyOnWriteList$ConverterImpl.unmarshal(CopyOnWriteList.java:184)
              at hudson.util.DescribableList$ConverterImpl.unmarshal(DescribableList.java:229)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
              at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
              at hudson.util.RobustReflectionConverter.unmarshallField(RobustReflectionConverter.java:261)
              at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:221)
              at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:172)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
              at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
              at com.thoughtworks.xstream.converters.collections.AbstractCollectionConverter.readItem(AbstractCollectionConverter.java:71)
              at hudson.util.RobustCollectionConverter.populateCollection(RobustCollectionConverter.java:82)
              at com.thoughtworks.xstream.converters.collections.CollectionConverter.unmarshal(CollectionConverter.java:61)
              at hudson.util.RobustCollectionConverter.unmarshal(RobustCollectionConverter.java:73)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
              at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
              at hudson.util.RobustReflectionConverter.unmarshallField(RobustReflectionConverter.java:261)
              at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:221)
              at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:172)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
              at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:137)
              at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.unmarshal(AbstractTreeMarshallingStrategy.java:33)
              at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:923)
              at hudson.util.XStream2.unmarshal(XStream2.java:70)
              at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:909)
              at hudson.XmlFile.unmarshal(XmlFile.java:148)
              ... 9 more
      

      Rolled back to 1.341

      kofemann.

      Attachments

        Activity

          kofemann kofemann added a comment -

          Just got a main from other user observing the same problem:

          I have the same problem on debian with local hudson.
          It is not working since the last version update.
          I am not able to post this details on the issue tracking system, so please add my OS, this may be helpfull and contact me if any details are needed, I also want this ticket to be timely resolved

          kofemann kofemann added a comment - Just got a main from other user observing the same problem: I have the same problem on debian with local hudson. It is not working since the last version update. I am not able to post this details on the issue tracking system, so please add my OS, this may be helpfull and contact me if any details are needed, I also want this ticket to be timely resolved
          mdonohue mdonohue added a comment -

          Does that other user also have the 'sectioned-view' plugin installed?

          mdonohue mdonohue added a comment - Does that other user also have the 'sectioned-view' plugin installed?

          Ah, this is caused by my removal of the ListViewColumn DESCRIPTOR static instances from the implementations in core. The sectioned view plugin must be referencing them.

          kohsuke Kohsuke Kawaguchi added a comment - Ah, this is caused by my removal of the ListViewColumn DESCRIPTOR static instances from the implementations in core. The sectioned view plugin must be referencing them.

          Code changed in hudson
          User: : kohsuke
          Path:
          trunk/hudson/main/core/src/main/java/hudson/util/CopyOnWriteList.java
          trunk/hudson/main/core/src/main/java/hudson/util/RobustCollectionConverter.java
          trunk/hudson/main/core/src/main/java/hudson/util/RobustReflectionConverter.java
          trunk/www/changelog.html
          http://jenkins-ci.org/commit/26445
          Log:
          JENKINS-5383 improving the XStream converters so that a linkage error in a plugin doesn't cause catastrophic start up failure.

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : kohsuke Path: trunk/hudson/main/core/src/main/java/hudson/util/CopyOnWriteList.java trunk/hudson/main/core/src/main/java/hudson/util/RobustCollectionConverter.java trunk/hudson/main/core/src/main/java/hudson/util/RobustReflectionConverter.java trunk/www/changelog.html http://jenkins-ci.org/commit/26445 Log: JENKINS-5383 improving the XStream converters so that a linkage error in a plugin doesn't cause catastrophic start up failure.

          Already fixed in sectioned-view plugin 1.7 (in rev.26289)

          kohsuke Kohsuke Kawaguchi added a comment - Already fixed in sectioned-view plugin 1.7 (in rev.26289)
          kofemann kofemann added a comment -

          i have updated hudson to 1.342 and sectioned-view plugin to 1.7.
          Works as expected. You can close the ticket.

          kofemann kofemann added a comment - i have updated hudson to 1.342 and sectioned-view plugin to 1.7. Works as expected. You can close the ticket.

          People

            tbingaman Timothy Bingaman
            kofemann kofemann
            Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: