Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-541

Hudson should check the compatibility of plugin and report an error

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: plugin-proposals
    • Labels:
      None
    • Environment:
      Platform: All, OS: Linux
    • Similar Issues:

      Description

      Failed : polarion.hpi

      hudson.util.IOException2: Failed to initialize
      at hudson.PluginWrapper.(PluginWrapper.java:200)
      at hudson.PluginManager.(PluginManager.java:74)
      at hudson.model.Hudson.(Hudson.java:183)
      at hudson.WebAppMain.contextInitialized(WebAppMain.java:84)
      at
      org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3763)
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:4211)
      at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:759)
      at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:739)
      at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:524)
      at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:809)
      at org.apache.catalina.startup.HostConfig.deployWARs(HostConfig.java:698)
      at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:472)
      at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1122)
      at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:310)
      at
      org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1021)
      at org.apache.catalina.core.StandardHost.start(StandardHost.java:718)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1013)
      at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:442)
      at org.apache.catalina.core.StandardService.start(StandardService.java:450)
      at org.apache.catalina.core.StandardServer.start(StandardServer.java:709)
      at org.apache.catalina.startup.Catalina.start(Catalina.java:551)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:294)
      at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:432)
      Caused by: java.lang.NoClassDefFoundError: hudson/scm/RepositoryBrowsers
      at hudson.plugins.polarion.PluginImpl.start(PluginImpl.java:17)
      at hudson.PluginWrapper.(PluginWrapper.java:197)
      ... 27 more

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          The underlying problem is that the plugin you've installed needs a newer version
          of Hudson. Plugin download page should have mentioned the Hudson version number
          with which the plugin is compatible.

          What we need to do is to automate that check.

          I updated the issue to reflect the nature of the work.

          kohsuke Kohsuke Kawaguchi added a comment -
              • Issue 2505 has been marked as a duplicate of this issue. ***
          mindless Alan Harder added a comment -

          I added such a warning in the plugin manager in 1.334

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : mindless
          Path:
          trunk/www/changelog.html
          http://fisheye4.cenqua.com/changelog/hudson/?cs=23976
          Log:
          [FIXED JENKINS-541] add issue link for plugin compatibility warning added in 1.334


            People

            Assignee:
            mindless Alan Harder
            Reporter:
            elassad elassad
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: