Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-54543

Jenkins job doesn't show commits from perforce

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Not A Defect
    • p4-plugin, scm-api-plugin
    • None
    • Master on Centos 7.5 64bit with openjdk 1.8.0_181
      Generic Java package
      Slave on win7 64bit with Java 8
      Jenkins: 2.149
      perforce p4v/ntx64/2017.1
      Google chrome v70

    Description

      Job is configured as pipeline script from SCM (perforce)
      Job is called on windows slave agent.
      Jenkins job doesn't display information about existing commits/changes (which exists) - his changelog is empty. He doesn't display it on job page (at #job execution / date / NO CHANGES) and in log during execution of checkout scm. Although he downloads new version of changed file.
      What is interesting when you use "replay" button, it works properly - it always displays existing changes.
      What is more, when you call job using jenkins-cli in jenkins-cli log you can see commits, but in job log doesn't

      attachments:

      • logs from both jobs (from build and replay botton)¬†
      • plugins list¬†

      Attachments

        Activity

          kolas Michal Kolas added a comment - - edited

          root cause of such behaviour is checkbox of lightweight checkout

          kolas Michal Kolas added a comment - - edited root cause of such behaviour is checkbox of lightweight checkout

          People

            Unassigned Unassigned
            kolas Michal Kolas
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: