Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-55159

Installing MicroFocus HP Automation tools plugin breaks Jenkins v2.150.1

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Blocker
    • Resolution: Fixed

    Description

      I've recently upgraded our Jenkins to the latest/greatest LTS (v2.150.1) and have upgraded all installed plugins.  Another group in our company has another Jenkins installation and is interested in consolidating our Jenkins footprint.  They require the HP/MicroFocus Automation Tools plugin for their work and when I try to install this plugin via the Jenkins Plugin installer (v5.6), our Jenkins server restarts in an error condition and you cannot login or utilize any Jenkins functionality.  I tried downgrading to the v5.5 and v5.5.4-beta versions of the HP/MicroFocus plugin, but that did not fix the problem.  The only fix is to stop jenkins, manually remove the plugin, then start Jenkins.

      Unfortunately, I don't have a stack trace as getting our Jenkins back up and running with all of the slaves is a bit of a pain, but I may be able to reproduce this later.

      Attachments

        Issue Links

          Activity

            OK, I couldn't leave this hanging without more details.  I'm going to attach 3 screen shots to this comment in addition to the text of the stack trace. 

            The first screenshot shows the state of available plugin updates, indicating that I'm not upgrading 4 plugins due to warnings about potential conflicts and configuration issues (until those are resolved or we have time to test them).

            The second screenshot shows the selection of the HP/MicroFocus plugin from the Jenkins Update Center.

            The third screenshot shows the status of Jenkins after installing the plugin, resetting, "getting ready to work", and achieving an unusable state.  It also shows the stack trace.  I'll also paste the text of the stack trace to facilitate copy/paste.

             

            ----------

            Stack Trace:

            java.lang.NullPointerExceptionjava.lang.NullPointerException at hudson.plugins.copyartifact.BuildSelectorParameter.initAliases(BuildSelectorParameter.java:159)Caused: java.lang.reflect.InvocationTargetException at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:104)Caused: java.lang.Error at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:110) at hudson.init.TaskMethodFinder$TaskImpl.run(TaskMethodFinder.java:175) at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:296) at jenkins.model.Jenkins$5.runTask(Jenkins.java:1083) at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:214) at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) at java.lang.Thread.run(Thread.java:748)Caused: org.jvnet.hudson.reactor.ReactorException at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:282) at jenkins.InitReactorRunner.run(InitReactorRunner.java:48) at jenkins.model.Jenkins.executeReactor(Jenkins.java:1117) at jenkins.model.Jenkins.<init>(Jenkins.java:921) at hudson.model.Hudson.<init>(Hudson.java:85) at hudson.model.Hudson.<init>(Hudson.java:81) at hudson.WebAppMain$3.run(WebAppMain.java:233)Caused: hudson.util.HudsonFailedToLoad at hudson.WebAppMain$3.run(WebAppMain.java:250)

            ----------

            benjamin_watson Benjamin Watson added a comment - OK, I couldn't leave this hanging without more details.  I'm going to attach 3 screen shots to this comment in addition to the text of the stack trace.  The first screenshot shows the state of available plugin updates, indicating that I'm not upgrading 4 plugins due to warnings about potential conflicts and configuration issues (until those are resolved or we have time to test them). The second screenshot shows the selection of the HP/MicroFocus plugin from the Jenkins Update Center. The third screenshot shows the status of Jenkins after installing the plugin, resetting, "getting ready to work", and achieving an unusable state.  It also shows the stack trace.  I'll also paste the text of the stack trace to facilitate copy/paste.   ---------- Stack Trace: java.lang.NullPointerExceptionjava.lang.NullPointerException at hudson.plugins.copyartifact.BuildSelectorParameter.initAliases(BuildSelectorParameter.java:159)Caused: java.lang.reflect.InvocationTargetException at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:104)Caused: java.lang.Error at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:110) at hudson.init.TaskMethodFinder$TaskImpl.run(TaskMethodFinder.java:175) at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:296) at jenkins.model.Jenkins$5.runTask(Jenkins.java:1083) at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:214) at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) at java.lang.Thread.run(Thread.java:748)Caused: org.jvnet.hudson.reactor.ReactorException at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:282) at jenkins.InitReactorRunner.run(InitReactorRunner.java:48) at jenkins.model.Jenkins.executeReactor(Jenkins.java:1117) at jenkins.model.Jenkins.<init>(Jenkins.java:921) at hudson.model.Hudson.<init>(Hudson.java:85) at hudson.model.Hudson.<init>(Hudson.java:81) at hudson.WebAppMain$3.run(WebAppMain.java:233)Caused: hudson.util.HudsonFailedToLoad at hudson.WebAppMain$3.run(WebAppMain.java:250) ----------

            Similar issue. Found something like this in startup logs: java.lang.NoClassDefFoundError: hudson/maven/MavenBuild

            Installing Maven Integration plugin solved and issue.

            artem_shorokhov Artem Shorokhov added a comment - Similar issue. Found something like this in startup logs: java.lang.NoClassDefFoundError: hudson/maven/MavenBuild Installing  Maven Integration plugin  solved and issue.

            I installed the Maven Integration Plugin, safely restarted Jenkins, then installed the HP/MicroFocus plugin, restarted Jenkins, and all seems well.  Thanks for the tip artem_shorokhov

            benjamin_watson Benjamin Watson added a comment - I installed the Maven Integration Plugin, safely restarted Jenkins, then installed the HP/MicroFocus plugin, restarted Jenkins, and all seems well.  Thanks for the tip artem_shorokhov
            gront Daniel Gront added a comment -

            radislavb, Is there a chance we missing a package?

            gront Daniel Gront added a comment - radislavb , Is there a chance we missing a package?
            gront Daniel Gront added a comment -

            The plugin's v5.6.1 is released to prevent dependency issue in installation.

            gront Daniel Gront added a comment - The plugin's v5.6.1 is released to prevent dependency issue in installation.

            People

              gront Daniel Gront
              benjamin_watson Benjamin Watson
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: