Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-55669

Auth plugin doesn't work after upgrade to Jenkins 2.150.2

    XMLWordPrintable

    Details

    • Similar Issues:
    • Released As:
      2.3.0

      Description

      Keycloak plugin is broken after 2.150.2 update, as described here is this other OpenID Connect plugin:

      https://github.com/jenkinsci/oic-auth-plugin/issues/54

       

      Also seems related to:

      https://issues.jenkins-ci.org/browse/JENKINS-55668

        Attachments

          Issue Links

            Activity

            Hide
            vinvij2016 Vin v added a comment - - edited

            Same issue observed. Infinite loop after upgrading from 2.150.1 to 2.150.2. Rolled back to 2.150.1 for the time being.

            Show
            vinvij2016 Vin v added a comment - - edited Same issue observed. Infinite loop after upgrading from 2.150.1 to 2.150.2. Rolled back to 2.150.1 for the time being.
            Hide
            wfollonier Wadeck Follonier added a comment -

            Bruno Medeiros Please could you test with the PR I proposed here: https://github.com/jenkinsci/keycloak-plugin/pull/5 ?

            Show
            wfollonier Wadeck Follonier added a comment - Bruno Medeiros Please could you test with the PR I proposed here: https://github.com/jenkinsci/keycloak-plugin/pull/5 ?
            Hide
            devlauer D. Lauer added a comment -

            The PR of Wadeck Follonier fixed the problem. Everything was merged, tested locally and released.
            Please update to the new version 2.3.0, which will show up in the update center in the next hours, and give me some feedback on this fix.

            Show
            devlauer D. Lauer added a comment - The PR of Wadeck Follonier fixed the problem. Everything was merged, tested locally and released. Please update to the new version 2.3.0, which will show up in the update center in the next hours, and give me some feedback on this fix.
            Hide
            mbischoff Michael Bischoff added a comment -

            oic-auth-plugin 1.5 fixing this issue has been released and should also show up in the next hours.

            Show
            mbischoff Michael Bischoff added a comment - oic-auth-plugin 1.5 fixing this issue has been released and should also show up in the next hours.
            Hide
            vinvij2016 Vin v added a comment -

            Can confirm, it works fine now. 

            Show
            vinvij2016 Vin v added a comment - Can confirm, it works fine now. 

              People

              Assignee:
              brunojcm Bruno Medeiros
              Reporter:
              brunojcm Bruno Medeiros
              Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: