Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-55669

Auth plugin doesn't work after upgrade to Jenkins 2.150.2

    XMLWordPrintable

Details

    • 2.3.0

    Description

      Keycloak plugin is broken after 2.150.2 update, as described here is this other OpenID Connect plugin:

      https://github.com/jenkinsci/oic-auth-plugin/issues/54

       

      Also seems related to:

      https://issues.jenkins-ci.org/browse/JENKINS-55668

      Attachments

        Issue Links

          Activity

            brunojcm Bruno Medeiros created issue -
            brunojcm Bruno Medeiros made changes -
            Field Original Value New Value
            Description Keycloak plugin is broken after 2.150.2 update, as described here is this other OpenID Connect plugin:

            [https://github.com/jenkinsci/oic-auth-plugin/issues/54]

             

            Also seems related to:

            https://issues.jenkins-ci.org/browse/JENKINS-55668
            vinvij2016 Vin v added a comment - - edited

            Same issue observed. Infinite loop after upgrading from 2.150.1 to 2.150.2. Rolled back to 2.150.1 for the time being.

            vinvij2016 Vin v added a comment - - edited Same issue observed. Infinite loop after upgrading from 2.150.1 to 2.150.2. Rolled back to 2.150.1 for the time being.

            brunojcm Please could you test with the PR I proposed here: https://github.com/jenkinsci/keycloak-plugin/pull/5 ?

            wfollonier Wadeck Follonier added a comment - brunojcm Please could you test with the PR I proposed here: https://github.com/jenkinsci/keycloak-plugin/pull/5 ?
            flow Florian Schmaus made changes -
            Link This issue is related to JENKINS-55683 [ JENKINS-55683 ]
            danielbeck Daniel Beck made changes -
            Labels security-901
            devlauer D. Lauer made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            devlauer D. Lauer added a comment -

            The PR of wfollonier fixed the problem. Everything was merged, tested locally and released.
            Please update to the new version 2.3.0, which will show up in the update center in the next hours, and give me some feedback on this fix.

            devlauer D. Lauer added a comment - The PR of wfollonier fixed the problem. Everything was merged, tested locally and released. Please update to the new version 2.3.0, which will show up in the update center in the next hours, and give me some feedback on this fix.
            devlauer D. Lauer made changes -
            Resolution Fixed [ 1 ]
            Status In Progress [ 3 ] Resolved [ 5 ]
            devlauer D. Lauer made changes -
            Assignee D. Lauer [ devlauer ] Bruno Medeiros [ brunojcm ]

            oic-auth-plugin 1.5 fixing this issue has been released and should also show up in the next hours.

            mbischoff Michael Bischoff added a comment - oic-auth-plugin 1.5 fixing this issue has been released and should also show up in the next hours.
            wfollonier Wadeck Follonier made changes -
            Released As 2.3.0
            wfollonier Wadeck Follonier made changes -
            Labels security-901 regression security-901
            vinvij2016 Vin v added a comment -

            Can confirm, it works fine now. 

            vinvij2016 Vin v added a comment - Can confirm, it works fine now. 

            People

              brunojcm Bruno Medeiros
              brunojcm Bruno Medeiros
              Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: