Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56086

Tabs missing in configuration page after adding plot to freestyle job

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Component/s: plot-plugin
    • Labels:
      None
    • Environment:
      at least Jenkins 2.121.2 to 2.150.2
    • Similar Issues:

      Description

      I have an issue with job's configure view. I've created freestyle project. No changes at all. After adding to "Post-build actions" new "Plot Build Data" everything seems OK.

      But when I saved the configuration and re-open configure view I cannot see the top (navigation) tabs in the page.

      Please see the attached screenshots.

       

      Best Regards

        Attachments

          Activity

          Hide
          smd Stefan Drissen added a comment - - edited

          I have the same issue. The plot plug-in is causing a JavaScript error in hudson.behavior.js:

          hudson-behavior.js:424 Uncaught TypeError: Cannot read property 'firstChild' of undefined
           at registerValidator (hudson-behavior.js:424)
           at Array.forEach (<anonymous>)
           at behavior.js:111
           at Array.forEach (<anonymous>)
           at behavior.js:107
           at Array.forEach (<anonymous>)
           at Object.applySubtree (behavior.js:93)
           at select.js:269

          Seems to be the same issue as JENKINS-53182

          Show
          smd Stefan Drissen added a comment - - edited I have the same issue. The plot plug-in is causing a JavaScript error in hudson.behavior.js: hudson-behavior.js:424 Uncaught TypeError: Cannot read property 'firstChild' of undefined at registerValidator (hudson-behavior.js:424) at Array.forEach (<anonymous>) at behavior.js:111 at Array.forEach (<anonymous>) at behavior.js:107 at Array.forEach (<anonymous>) at Object .applySubtree (behavior.js:93) at select.js:269 Seems to be the same issue as JENKINS-53182
          Hide
          pedritter Pedro Gutierrez added a comment - - edited

          Same problem here

          I can't see, however, the same js error reported by Stefan Drissen.

          Surprisingly, when I refresh the page (F5, many times) navigation tabs reappear but then other styles in the page break. 

           

          Show
          pedritter Pedro Gutierrez added a comment - - edited Same problem here I can't see, however, the same js error reported by Stefan Drissen. Surprisingly, when I refresh the page (F5, many times) navigation tabs reappear but then other styles in the page break.   
          Hide
          pedritter Pedro Gutierrez added a comment -

          Show
          pedritter Pedro Gutierrez added a comment -
          Hide
          smd Stefan Drissen added a comment -

          I can confirm that the javascript error is gone, but that the layout is still sub-optimal (even on the initial load the panels are extending past their containers).
          Also someone seems to have left some debug code behind in configure.js which is repeatedly spamming the console:

          console.log("dynWidth=" + dynamicViewPortWidth + ", statWidth=" + staticViewPortWidth);
          
          Show
          smd Stefan Drissen added a comment - I can confirm that the javascript error is gone, but that the layout is still sub-optimal (even on the initial load the panels are extending past their containers). Also someone seems to have left some debug code behind in configure.js which is repeatedly spamming the console: console.log( "dynWidth=" + dynamicViewPortWidth + ", statWidth=" + staticViewPortWidth);

            People

            Assignee:
            vgaidarji Veaceslav Gaidarji
            Reporter:
            silvam Michał Marcinkowski
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated: