Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56239

Gradle cache locked

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Trivial
    • Resolution: Not A Defect
    • Component/s: gradle-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.150.2
      Gradle Plugin version 1.28
      Gradle version 4.2.1 on Linux server
    • Similar Issues:

      Description

      Locks are not being released on the Gradle cache so other jobs are failing waiting for the locks to be released.

      Debug message from Jenkins log:  [DEBUG] [org.gradle.cache.internal.DefaultFileLockManager] The file lock is held by a different Gradle process (pid: 3265, operation: ). Will attempt to ping owner at port 42238

       

      The lock file is not being deleted after builds complete.

      Full log attached.

        Attachments

          Activity

          wolfs Stefan Wolf added a comment -

          Jed Jacobs: I don't think this has anything to do with the Gradle plugin. This is an issue with Gradle or the usage of Gradle.

          Do you have two Gradle build run in parallel on the same machine?

          Do your Gradle builds share the same user home?

          What is the other process which is noted in the log doing?

          x102785 Jed Jacobs added a comment -

          Hi Stefan.  We have more than one build on the same machine but they were not running concurrently.
          The Gradle builds all run with the same account so yes, they share the same user home and Gradle cache then, by default.

          The only other process is the git plugin get the files from BitBucket.

          I should mention, this is a scripted pipeline.

          x102785 Jed Jacobs added a comment -

          Issue not caused by the Gradle Plugin.  We found a rogue process on the server that had not released locks on over 1000 dependencies.  Killing the process and deleting the locks resolved the issue.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            x102785 Jed Jacobs
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: