Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56524

When executing multiple builds with the same label expression plugin only launches one agent

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Not A Defect
    • Component/s: amazon-ecs-plugin
    • Labels:
      None
    • Environment:
      amazon-ecs plugin version 1.19
      Jenkins ver. 2.150.3
    • Similar Issues:

      Description

      Similiar to JENKINS-53001 but this is about old-style jobs.

      As seen on the screenshot concurrent builds of the same project are serialized because ECS plugin only provides 1 agent.

      When I try to execute 2 builds from separate projects, which have the same label expression only 1 agent is spawned, making the other build wait.

      The plugin configuration is as follows:

      <com.cloudbees.jenkins.plugins.amazonecs.ECSCloud@3de68a52 templates=[com.cloudbees.jenkins.plugins.amazonecs.ECSTaskTemplate@9780094] credentialsId= cluster=arn:aws:ecs:eu-central-1:1234:cluster/ew1-acme-2P3KCN8TWDUV regionName=eu-central-1 tunnel=null jenkinsUrl=http://REDACTED.eu-central-1.elb.amazonaws.com retentionTimeout=5 slaveTimeoutInSeconds=900 ecsService=com.cloudbees.jenkins.plugins.amazonecs.ECSService@772f46cb name=ecsTest actions=null>
      <com.cloudbees.jenkins.plugins.amazonecs.ECSTaskTemplate@9780094 templateName=jnlp-slave-with-dockerPiip label=ecs docker any ec2-deploy ec2 deploy taskDefinitionOverride=null image=jenkinsci/jnlp-slave remoteFSRoot=/var/jenkins_home memory=0 memoryReservation=1536 cpu=1 subnets= securityGroups= assignPublicIp=false dnsSearchDomains=null entrypoint=null taskrole=null executionRole=null repositoryCredentials=null jvmArgs=null mountPoints=[MountPointEntry{name:docker, sourcePath:/var/run/docker.sock, containerPath:/var/run/docker.sock, readOnly:false}, MountPointEntry{name:jenkins-workspace, sourcePath:/mnt/efs, containerPath:/var/jenkins_home, readOnly:false}] launchType=EC2 networkMode=default privileged=true containerUser=null environments=null extraHosts=null portMappings=null logDriver=null logDriverOptions=null>
      
      

        Attachments

          Activity

          jbochenski Jakub Bochenski added a comment -

          I think it was caused by the ECS stack lacking the capacity to start another task.

          Maybe the logs could be improved to make it easier to understand the cause


            People

            Assignee:
            roehrijn2 Jan Roehrich
            Reporter:
            jbochenski Jakub Bochenski
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: