Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56548

Support Joining Domains for Azure VM Plugin

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: _unsorted
    • Labels:
      None
    • Similar Issues:

      Description

      Currently the Azure VM plugin does not support joining the VMs to domains upon creation (only local admins), it would be helpful if we can get this option by default.

      On the other hand, attempting to join the VM to domains manually would require joining certain vnets and setting DNS servers for these VMs, but the plugin would then deprovision\delete the VMs upon reboot of the VM, not sure if it was intended behavior from the plugin.

      Example logs below:
      Feb 25, 2019 4:07:29 PM INFO com.microsoft.azure.vmagent.AzureVMAgent deprovision
      AzureVMAgent: deprovision: Deprovision called for agent nodes-tea6e560, for reason: Unknown reason

        Attachments

          Activity

          jieshe Jie Shen added a comment -

          Thanks for reporting the issue here. We will put this into our plan.

          timja Tim Jacomb added a comment -

          All issues have been transferred to GitHub.

          See https://github.com/jenkinsci/azure-vm-agents-plugin/issues

          Search the issue title to find it.

          (This is a bulk comment and can't link to the specific issue)


            People

            Assignee:
            jieshe Jie Shen
            Reporter:
            gpin1120 Phillip Chen
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: