Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56886

Missing test reports when using xUnit plugin

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: xunit-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.164.1, xUnit plugin 2.3.3
    • Similar Issues:

      Description

      We use the xUnit plugin to parse Unittest++ output files. On many of our projects, the number of tests reported in Jenkins fluctuates from build to build. I have verified that all our test output files are properly converted to jUnit test files, but either the plugin does not report them correctly to Jenkins or something is up in Jenkins itself.

      Not sure exactly what is needed to diagnose this - many of the data we have in our Jenkins is internal and cannot be shared, but if I can help with something I will.

        Attachments

          Activity

          nfalco Nikolas Falco added a comment - - edited

          I need unittest reports of two different build that report different count of total tests or I'm not able to reproduce the issue.

          clechasseurcoveo Charles Lechasseur added a comment -

          I'll try to get that as soon as possible. They might contain some sensitive data so I have to check them first.


            People

            Assignee:
            nfalco Nikolas Falco
            Reporter:
            clechasseurcoveo Charles Lechasseur
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: