Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-57882

junit Test Result Age shows next build number

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Fixed but Unreleased (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: junit-plugin
    • Labels:
    • Environment:
      jenkins 2.179
      junit plugin 1.28
      linux, running behind apache server
    • Similar Issues:

      Description

      Test results are being processed with the jUnit plugin ( latest version )

      The age displayed in the results shows the next build number

      Test         Duration Age

      myTest       0 ms    1035

      and the specific test results are:

      • Failing for the past 1,035 builds (Since #0 )

      This was build #1034, the next build will be #1035

      In the previous build the test was Skipped 

      #1032 Passed

      #1033 Skipped for the past 1,034 builds (Since #0 )

      #1034 Failing for the past 1,035 builds (Since #0 )

      Possible Regression or Feature - I have never seen this before 

       

        Attachments

        1. AfterSkipped.jpg
          AfterSkipped.jpg
          82 kB
        2. BeforeSkip.JPG
          BeforeSkip.JPG
          71 kB
        3. Skipped.jpg
          Skipped.jpg
          64 kB

          Issue Links

            Activity

            zbynek Zbynek Konecny added a comment -

            Thanks for the investigation, I'll try to fix it soon.

            sgjenkins Steve Graham added a comment -

            had to upgrade to version 1.29, only noticed since a test failed for the last 598 days when it was skipped in the last build and passed in the build previous to that.
            I went back to 1.27 and then screwed up all my warnings generations since there is a dependency in many other plugins for 1.29..
            Reloaded 1.29 but my warnings generation is still messed up - there are now no reported warnings.
            Hows it going with a fix?

            sgjenkins Steve Graham added a comment -

            Any progress with this ?
            I have test results which have been skipped for 1346 test runs ( job number is #1345 ) - its not correct.
            I have hundreds of developers really making fun of the results and I have to continually explain what happens.
            Thanks..

            sgjenkins Steve Graham added a comment -

            Still broken in LTS 2.277.1

            zbynek Zbynek Konecny added a comment - - edited

            Steve Graham this was released in JUnit 1.50 today

            The fix won't correct existing data, if a test is marked as failing since build 1, new builds will still show that it's failing since build 1. But after it's skipped once the age counter will reset.


              People

              Assignee:
              zbynek Zbynek Konecny
              Reporter:
              sgjenkins Steve Graham
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: