Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5843

Environments variables created by the parametrized build are not converted to all uppercase anymore

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Hudson runing on Mac Mini using Mac OS X 10.6.2 using a windows slave (running win XP)
    • Similar Issues:

      Description

      We use different task which are parametrized. When starting the build the user enters some information. The job uses an ant script to do its work. In this script we accessed the parametrized data as follow:

      <property environment="env"/>
      <target name="hudson">
      <!-- Determines if we need to update the version -->
      <condition property="needVersionChange">
      <istrue value="${env.CHANGE_VERSION}"/>
      </condition>
      <echo>Need Version Change? ${needVersionChange}</echo>
      ...
      </target>

      Whereas the parameter field is configured as follows:
      Type: Drop-down
      Name: change_version
      Values: No Yes

      This was working now for around 6 Month without a problem. The lowercase field name was transformed to a uppercase environment name. I found this problem yesterday doing using hudson 1.347. The problem happens for all jobs independent if their are running on the windows node or on the mac itself.

      One workaround to fix it is to change the field configuration to use a uppercase name. But as I didn't found any information in the change log about a change in this part I hope I get a confirmation that this change was intended and this is the best solution to it.

      I also tried downgrading to the last two used versions (1.346 and 1.345) but the problem exist there also.

        Attachments

          Issue Links

            Activity

            vkodocha vkodocha added a comment -

            Seams like this problem is connected to this change. It is already fixed in the current revision (27151) in the trunk.

            slide_o_mix Alex Earl added a comment -

            This was fixed at some point, variables are changed to upper case


              People

              Assignee:
              kohsuke Kohsuke Kawaguchi
              Reporter:
              vkodocha vkodocha
              Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: