Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-58457

Not able to open JenkinsUI from slave machine when jenkins is installed via war package on master

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Not A Defect
    • Component/s: other
    • Labels:
      None
    • Similar Issues:

      Description

      I do not have much experience with Jenkins and am facing a weird issue which has got me puzzled.

      I have 2 machines say M1(master-Windows 10) and M2(slave-Windows 10) on the same network. I am able to ping M1 from M2 and vice-versa.

      On M1, when I:

      • install Jenkins as a Windows service, then from M2, I am able to access the JenkinsUI(via http://MachineName:8080)
      • install Jenkins using the generic war package, then from M2, I am not able to access the JenkinsUI(via http://MachineName:8080)

      Why I am not able to access the JenkinsUI from slave machine(M2) when I install Jenkins via war package even when the ping test is successful? Is there something I am missing? Has anyone ever faced such an issue before?

      Background: The reason I want to install Jenkins on M1 using the war package and not as a windows service is that I need to trigger my UI Test Automation Scripts on the slave machine, M2 which will not be triggered when Jenkins is installed as a service.

        Attachments

          Activity

          Hide
          gurman Gurmanjot Singh added a comment -

          Hi Team,

          I am really hoping to get a solution on this forum. Please help me with this issue. I never faced such an issue before. Recently, our existing Jenkins server machine had to be decommissioned. I am facing this issue while setting up jenkins on a new machine.

          Thanks,

          Gurman

          Show
          gurman Gurmanjot Singh added a comment - Hi Team, I am really hoping to get a solution on this forum. Please help me with this issue. I never faced such an issue before. Recently, our existing Jenkins server machine had to be decommissioned. I am facing this issue while setting up jenkins on a new machine. Thanks, Gurman
          Hide
          slide_o_mix Alex Earl added a comment -

          Just as an FYI, Jira is not a forum for asking questions. If you want to ask questions and have someone actually see it, you probably want to join the jenkins users mailing list and post there.

          Show
          slide_o_mix Alex Earl added a comment - Just as an FYI, Jira is not a forum for asking questions. If you want to ask questions and have someone actually see it, you probably want to join the jenkins users mailing list and post there.

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            gurman Gurmanjot Singh
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: