Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-59315

This agent is offline because Jenkins failed to launch the agent process on it.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: ssh-slaves-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.38, SSh slave agent 1.26
    • Similar Issues:

      Description

      when ever i launch the agent i am getting below error in the console:

      Warning: no key algorithms provided; JENKINS-42959 disabled

      [03/27/19 10:36:13] [SSH] Opening SSH connection to ​10.1.1.62​:22.

      ​10.1.1.62​

      java.io.IOException: There was a problem while connecting to ​10.1.1.62​:22

              at com.trilead.ssh2.Connection.connect(Connection.java:834)

              at hudson.plugins.sshslaves.SSHLauncher.openConnection(SSHLauncher.java:1324)

              at hudson.plugins.sshslaves.SSHLauncher$2.call(SSHLauncher.java:831)

              at hudson.plugins.sshslaves.SSHLauncher$2.call(SSHLauncher.java:820)

              at java.util.concurrent.FutureTask.run(FutureTask.java:266)

              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

              at java.lang.Thread.run(Thread.java:745)

      Caused by: java.net.UnknownHostException: ​10.1.1.62​

              at java.net.InetAddress.getAllByName0(InetAddress.java:1259)

              at java.net.InetAddress.getAllByName(InetAddress.java:1171)

              at java.net.InetAddress.getAllByName(InetAddress.java:1105)

              at java.net.InetAddress.getByName(InetAddress.java:1055)

              at com.trilead.ssh2.transport.TransportManager.createInetAddress(TransportManager.java:166)

              at com.trilead.ssh2.transport.TransportManager.establishConnection(TransportManager.java:366)

              at com.trilead.ssh2.transport.TransportManager.initialize(TransportManager.java:480)

              at com.trilead.ssh2.Connection.connect(Connection.java:774)

              ... 7 more

      [03/27/19 10:36:13] Launch failed - cleaning up connection

      [03/27/19 10:36:13] [SSH] Connection closed.

        Attachments

          Activity

          ifernandezcalvo Ivan Fernandez Calvo added a comment -

          version out of support


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            narayask Sanjeev Kumar Narayanaswamy
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: