Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-596

404 error when modifying System Configuration

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: Windows XP
    • Similar Issues:

      Description

      Using IE6 on WinXP as browser - also confirmed by Kohsuke with IE7. Firefox
      does not show the same problem.

      When I modify the system configuration I'm met with a 404 page.

      Win XP 32bit jdk 1.6.0_01.
      I Downloaded Hudson 1.109 from hudson.dev.java.net
      Placed the jar in c:\Hudson

      Start cmd.exe
      Set HUDSON_HOME=c:\Hudson\Work
      run java -jar hudson.jar

      (see output in console)

      Go to http://localhost:8080

      See main page.

      Go to Manage Hudson and System Configuration Make a change to anything (add jdk
      and or maven) and click ok
      get a 404 page

      Status Code: 404
      Exception:
      Stacktrace:
      (none)

      ------------------------------------------------------------------------
      --------
      Generated by Winstone Servlet Engine v0.9.8 at Wed Jun 13
      14:19:08 BST 2007

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          I put a workaround in Hudson to avoid this problem with the system configuration
          for 1.112.

          There are a few other less prominent places that are affected by this bug, so
          I'm keeping this bug open until Winstone fixes it and the fix gets integrated
          into Hudosn.

          kohsuke Kohsuke Kawaguchi added a comment -

          Picked up Winstone 0.9.9 in Hudson 1.117 to fix this problem.

          kohsuke Kohsuke Kawaguchi added a comment -

          Supposed to be marked as fixed.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            teilo James Nord
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: