Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-59899

java.lang.NoSuchMethodError: io.jenkins.plugins.forensics.blame.BlamerFactory.findBlamerFor

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: forensics-api-plugin
    • Labels:
      None
    • Environment:
      Forensics-api-plugin 0.5.0
    • Similar Issues:
    • Released As:
      warnings-ng 7.0.0

      Description

      HI!

      I get the following error with the new Version 0.5.0: (on Ubuntu)

      10:32:20  [PMD] -> found 126 issues (skipped 21 duplicates)
      Error when executing always post condition:
      java.lang.NoSuchMethodError: io.jenkins.plugins.forensics.blame.BlamerFactory.findBlamerFor(Lhudson/model/Run;Lhudson/FilePath;Lhudson/model/TaskListener;Lio/jenkins/plugins/forensics/util/FilteredLog;)Lio/jenkins/plugins/forensics/blame/Blamer;
      	at io.jenkins.plugins.analysis.core.steps.IssuesScanner.createBlamer(IssuesScanner.java:136)
      	at io.jenkins.plugins.analysis.core.steps.IssuesScanner.postProcess(IssuesScanner.java:120)
      	at io.jenkins.plugins.analysis.core.steps.IssuesScanner.scan(IssuesScanner.java:98)
      	at io.jenkins.plugins.analysis.core.steps.IssuesRecorder.scanWithTool(IssuesRecorder.java:604)
      	at io.jenkins.plugins.analysis.core.steps.IssuesRecorder.record(IssuesRecorder.java:570)
      	at io.jenkins.plugins.analysis.core.steps.IssuesRecorder.perform(IssuesRecorder.java:540)
      	at io.jenkins.plugins.analysis.core.steps.RecordIssuesStep$Execution.run(RecordIssuesStep.java:956)
      	at io.jenkins.plugins.analysis.core.steps.RecordIssuesStep$Execution.run(RecordIssuesStep.java:919)
      	at org.jenkinsci.plugins.workflow.steps.SynchronousNonBlockingStepExecution.lambda$start$0(SynchronousNonBlockingStepExecution.java:47)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
      	at java.lang.Thread.run(Thread.java:748)
      

      When I downgrad to 0.4.1 it's working again.

      regards Alex

       

       

       

        Attachments

          Activity

          Hide
          drulli Ulli Hafner added a comment -

          Please upgrade warnings-ng to 7.0.0 as well.

          Show
          drulli Ulli Hafner added a comment - Please upgrade warnings-ng to 7.0.0 as well.

            People

            Assignee:
            drulli Ulli Hafner
            Reporter:
            alexz707 Alex Z
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: