Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-60103

Cannot send junit results to Octane, because there is no permission on slave to create log folder

    XMLWordPrintable

Details

    Description

      Cannot sent JUnits results to Octane while using  Micro Focus Application Automation Tools v5.9

      When I do downgrade to v5.7 everything working fine

      Issue LOGS

       

      08/11/2019 10:13:30,836 INFO [EventsServiceWorker-339 ] EventsServiceImpl : https://octane.orange-labs.fr?p=1001 sending [Run test:73:FINISHED, Declarative: Post Actions:73:STARTED] event/s ...
      08/11/2019 10:13:32,922 INFO [EventsServiceWorker-339 ] EventsServiceImpl : https://octane.orange-labs.fr?p=1001 sending [Declarative: Post Actions:73:FINISHED] event/s ...
      08/11/2019 10:13:34,009 INFO [Running CpsFlowExecutionOwner[functional/73:functional #73]] RunListenerForLogs : enqueued build 'functional #73' for log submission
      08/11/2019 10:13:34,080 ERROR [Running CpsFlowExecutionOwner[functional/73:functional #73]] TestListener : failed to process test results
      java.io.IOException: Remote call on olsauto1 failed
      at hudson.remoting.Channel.call(Channel.java:963) ~[remoting-3.29.jar:?]
      at hudson.FilePath.act(FilePath.java:1070) ~[jenkins-core-2.176.3.jar:?]
      at hudson.FilePath.act(FilePath.java:1059) ~[jenkins-core-2.176.3.jar:?]
      at com.microfocus.application.automation.tools.octane.tests.junit.JUnitExtension.getTestResults(JUnitExtension.java:95) ~[hp-application-automation-tools-plugin.jar:5.9]
      at com.microfocus.application.automation.tools.octane.tests.TestListener.processBuild(TestListener.java:56) [hp-application-automation-tools-plugin.jar:5.9]
      at com.microfocus.application.automation.tools.octane.events.WorkflowListenerOctaneImpl.sendPipelineFinishedEvent(WorkflowListenerOctaneImpl.java:132) [hp-application-automation-tools-plugin.jar:5.9]
      at com.microfocus.application.automation.tools.octane.events.WorkflowListenerOctaneImpl.onNewHead(WorkflowListenerOctaneImpl.java:83) [hp-application-automation-tools-plugin.jar:5.9]
      at org.jenkinsci.plugins.workflow.cps.CpsFlowExecution.notifyListeners(CpsFlowExecution.java:1450) [workflow-cps.jar:2.62]
      at org.jenkinsci.plugins.workflow.cps.CpsThreadGroup$3.run(CpsThreadGroup.java:417) [workflow-cps.jar:2.62]
      at org.jenkinsci.plugins.workflow.cps.CpsVmExecutorService$1.run(CpsVmExecutorService.java:35) [workflow-cps.jar:2.62]
      at hudson.remoting.SingleLaneExecutorService$1.run(SingleLaneExecutorService.java:131) [remoting-3.29.jar:?]
      at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28) [jenkins-core-2.176.3.jar:?]
      at jenkins.security.ImpersonatingExecutorService$1.run(ImpersonatingExecutorService.java:59) [jenkins-core-2.176.3.jar:?]
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_222]
      at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_222]
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_222]
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_222]
      at java.lang.Thread.run(Thread.java:748) [?:1.8.0_222]
      Caused by: java.lang.NoClassDefFoundError: Could not initialize class com.microfocus.application.automation.tools.octane.tests.junit.JUnitXmlIterator
      at com.microfocus.application.automation.tools.octane.tests.junit.JUnitExtension$GetJUnitTestResults.invoke(JUnitExtension.java:219) ~[hp-application-automation-tools-plugin.jar:5.9]
      at com.microfocus.application.automation.tools.octane.tests.junit.JUnitExtension$GetJUnitTestResults.invoke(JUnitExtension.java:130) ~[hp-application-automation-tools-plugin.jar:5.9]
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:3050) ~[jenkins-core-2.176.3.jar:?]
      at hudson.remoting.UserRequest.perform(UserRequest.java:212) ~[remoting-3.29.jar:?]
      at hudson.remoting.UserRequest.perform(UserRequest.java:54) ~[remoting-3.29.jar:?]
      at hudson.remoting.Request$2.run(Request.java:369) ~[remoting-3.29.jar:?]
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72) ~[remoting-3.29.jar:?]
      at java.util.concurrent.FutureTask.run(FutureTask.java:264) ~[?:1.8.0_222]
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1135) ~[?:1.8.0_222]
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635) ~[?:1.8.0_222]
      at java.lang.Thread.run(Thread.java:844) ~[?:1.8.0_222]
      Suppressed: hudson.remoting.Channel$CallSiteStackTrace: Remote call to olsauto1
      at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1743) ~[remoting-3.29.jar:?]
      at hudson.remoting.UserRequest$ExceptionResponse.retrieve(UserRequest.java:357) ~[remoting-3.29.jar:?]
      at hudson.remoting.Channel.call(Channel.java:957) ~[remoting-3.29.jar:?]
      at hudson.FilePath.act(FilePath.java:1070) ~[jenkins-core-2.176.3.jar:?]
      at hudson.FilePath.act(FilePath.java:1059) ~[jenkins-core-2.176.3.jar:?]
      at com.microfocus.application.automation.tools.octane.tests.junit.JUnitExtension.getTestResults(JUnitExtension.java:95) ~[hp-application-automation-tools-plugin.jar:5.9]
      at com.microfocus.application.automation.tools.octane.tests.TestListener.processBuild(TestListener.java:56) [hp-application-automation-tools-plugin.jar:5.9]
      at com.microfocus.application.automation.tools.octane.events.WorkflowListenerOctaneImpl.sendPipelineFinishedEvent(WorkflowListenerOctaneImpl.java:132) [hp-application-automation-tools-plugin.jar:5.9]
      at com.microfocus.application.automation.tools.octane.events.WorkflowListenerOctaneImpl.onNewHead(WorkflowListenerOctaneImpl.java:83) [hp-application-automation-tools-plugin.jar:5.9]
      at org.jenkinsci.plugins.workflow.cps.CpsFlowExecution.notifyListeners(CpsFlowExecution.java:1450) [workflow-cps.jar:2.62]
      at org.jenkinsci.plugins.workflow.cps.CpsThreadGroup$3.run(CpsThreadGroup.java:417) [workflow-cps.jar:2.62]
      at org.jenkinsci.plugins.workflow.cps.CpsVmExecutorService$1.run(CpsVmExecutorService.java:35) [workflow-cps.jar:2.62]
      at hudson.remoting.SingleLaneExecutorService$1.run(SingleLaneExecutorService.java:131) [remoting-3.29.jar:?]
      at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28) [jenkins-core-2.176.3.jar:?]
      at jenkins.security.ImpersonatingExecutorService$1.run(ImpersonatingExecutorService.java:59) [jenkins-core-2.176.3.jar:?]
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_222]
      at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_222]
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_222]
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_222]
      at java.lang.Thread.run(Thread.java:748) [?:1.8.0_222]

       

      What I did to resolve issue:

      *reboot -slave

      *check java version on slave: openjdk 10.0.2 2018-07-17

      nothing helped. Only downgrade to 5.7 fix issue

      Attachments

        Activity

          pretbc pretbc pretbc created issue -
          narcisamgalan Maria Narcisa Galan made changes -
          Field Original Value New Value
          Assignee Maria Narcisa Galan [ narcisamgalan ] Radi Berkovich [ radislavb ]

          Hi

          do you have additional slaves?

          Is it occur with all slaves?

          is it occur with all jobs?

          radislavb Radi Berkovich added a comment - Hi do you have additional slaves? Is it occur with all slaves? is it occur with all jobs?
          pretbc pretbc pretbc added a comment -

          Yes, i have 12 different slaves.
          No, issue occur only on 1 slave.
          Yes, for all jobs on that slave.

          I Run this slave using docker

          pretbc pretbc pretbc added a comment - Yes, i have 12 different slaves. No, issue occur only on 1 slave. Yes, for all jobs on that slave. I Run this slave using docker

          All other slave are not on docker?

          What about java? is it different on other slaves?

           

          radislavb Radi Berkovich added a comment - All other slave are not on docker? What about java? is it different on other slaves?  
          pretbc pretbc pretbc added a comment -

          All others have set only sh "python fooo/bar.py".
          And no Java is The same.
          On slave with issue i Run Docker aż follow:
          pipeline{
          agent{
          docker{
          label node
          image "foo"
          }
          }
          }

          But i dont know to be honest if docker is the issue here. Maybe Above logs from description can tell more? What is the different between ver 5.9 and 5.7?

          pretbc pretbc pretbc added a comment - All others have set only sh "python fooo/bar.py". And no Java is The same. On slave with issue i Run Docker aż follow: pipeline{ agent{ docker{ label node image "foo" } } } But i dont know to be honest if docker is the issue here. Maybe Above logs from description can tell more? What is the different between ver 5.9 and 5.7?
          radislavb Radi Berkovich added a comment - - edited

          Hi.

          In your supplied log, I see that problem is here :

          Caused by: java.lang.NoClassDefFoundError: Could not initialize class com.microfocus.application.automation.tools.octane.tests.junit.JUnitXmlIterator

          There is a tiny difference between 5.7 and 5.9 in this class, related to log initialization.

          Maybe because slave  on docker , it does not have permissions to open log file (its only my thoughts for now)

          I can prepare dev version with relevant code wrapped with try/catch - is it possible from your side - to install dev version for validation?

           

          radislavb Radi Berkovich added a comment - - edited Hi. In your supplied log, I see that problem is here : Caused by: java.lang.NoClassDefFoundError: Could not initialize class com.microfocus.application.automation.tools.octane.tests.junit.JUnitXmlIterator There is a tiny difference between 5.7 and 5.9 in this class, related to log initialization. Maybe because slave  on docker , it does not have permissions to open log file (its only my thoughts for now) I can prepare dev version with relevant code wrapped with try/catch - is it possible from your side - to install dev version for validation?  
          radislavb Radi Berkovich made changes -
          Summary Cannot send junit results to Octane Cannot send junit results to Octane, because there is no permission on slave to create log folder
          pretbc pretbc pretbc added a comment -

          Sure. I can give a try

          pretbc pretbc pretbc added a comment - Sure. I can give a try
          pretbc pretbc pretbc added a comment -

          any news regarding dev version ?

          pretbc pretbc pretbc added a comment - any news regarding dev version ?
          radislavb Radi Berkovich added a comment - Sorry for delay, I just wanted to release official beta version and it took some time   http://repo.jenkins-ci.org/releases/org/jenkins-ci/plugins/hp-application-automation-tools-plugin/5.9.3-beta/hp-application-automation-tools-plugin-5.9.3-beta.hpi  
          radislavb Radi Berkovich made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Fixed but Unreleased [ 10203 ]
          radislavb Radi Berkovich made changes -
          Status Fixed but Unreleased [ 10203 ] Closed [ 6 ]
          radislavb Radi Berkovich made changes -
          Resolution Fixed [ 1 ]
          Status Closed [ 6 ] Reopened [ 4 ]

          any updates?

           

          radislavb Radi Berkovich added a comment - any updates?  

          Version 6.0 released with the fix

          radislavb Radi Berkovich added a comment - Version 6.0 released with the fix
          radislavb Radi Berkovich made changes -
          Resolution Fixed [ 1 ]
          Status Reopened [ 4 ] Fixed but Unreleased [ 10203 ]
          radislavb Radi Berkovich made changes -
          Status Fixed but Unreleased [ 10203 ] Resolved [ 5 ]
          radislavb Radi Berkovich made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

          People

            radislavb Radi Berkovich
            pretbc pretbc pretbc
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: