Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-605

When a module's tests fail, hudson still kicks off dependent module builds

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Say I have a project with modules A and B, built under hudson using the 'clean
      deploy' as the goals. Further, say B has a dependency on A. When there's a
      change in the project, hudson will therefore build A followed by B.

      The problem is that if A's tests fail, A is not deployed. This is maven's
      behavior (and, IMO, correct). Hudson will still trigger B, which is a problem.

      Since A wasn't deployed, B will be looking at a previous locally installed
      version of A. If both A & B were changed at the same time (e.g., because the
      API A provides and B uses was changed), B will no longer compile against the old
      version of A. This means that B will have a build failure. This means the
      whole build will be marked as "failed" rather than "unstable," which obscures
      the real source of the problem.

      Since hudson knows that A's tests failed, would it be possible to have it not
      trigger B? (I.e., just like if A completely failed.)

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          Thanks for pointing this out. Fixed in 1.116.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            rsutphin rsutphin
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: