Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-606

Issues with Javadoc with multi-module build

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Trivial
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: Windows XP
    • Similar Issues:

      Description

      Hi - This is probably my misunderstanding, but maybe it's worth considering.

      I've got a project that's (mostly) an EAR and which is built as a multi-module
      Maven2 build. When I built it (by building the top-level pom.xml and letting
      that build the sub-projects), I can pickup the project-wide tests by setting the
      "Test report XMLs" as "TopUp2.Indosat/*/target/surefire-reports/.xml" but if I
      set the "Javadoc directory" as "TopUp2.Indosat/**/target/site/apidocs", I get
      the following error...

      ...
      Publishing Javadoc
      FATAL: Unable to copy Javadoc from D:\Java\Tools\Hudson\jobs\Indosat
      TopUp\workspace\TopUp2.Indosat/**/target/site/apidocs to
      D:\Java\Tools\Hudson\jobs\Indosat TopUp\javadoc
      hudson.util.IOException2: Failed to copy D:\Java\Tools\Hudson\jobs\Indosat
      TopUp\workspace\TopUp2.Indosat*\target\site\apidocs// to
      D:\Java\Tools\Hudson\jobs\Indosat TopUp\javadoc
      at hudson.FilePath$19.invoke(FilePath.java:680)
      at hudson.FilePath$19.invoke(FilePath.java:647)
      at hudson.FilePath.act(FilePath.java:239)
      at hudson.FilePath.copyRecursiveTo(FilePath.java:647)
      at hudson.FilePath.copyRecursiveTo(FilePath.java:633)
      at hudson.tasks.JavadocArchiver.perform(JavadocArchiver.java:62)
      at hudson.model.Build$RunnerImpl.post(Build.java:137)
      at hudson.model.Run.run(Run.java:572)
      at hudson.model.Build.run(Build.java:101)
      at hudson.model.Executor.run(Executor.java:59)
      Caused by: D:\Java\Tools\Hudson\jobs\Indosat
      TopUp\workspace\TopUp2.Indosat**\target\site\apidocs not found.
      at
      org.apache.tools.ant.types.AbstractFileSet.getDirectoryScanner(AbstractFileSet.java:422)
      at org.apache.tools.ant.taskdefs.Copy.execute(Copy.java:453)
      at hudson.FilePath$19.invoke(FilePath.java:677)
      ... 9 more
      Recording test results
      finished: FAILURE

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          Javadoc field doesn't accept wildcards. Improved form validation in 1.116.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            gwynevans gwynevans
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: