Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-607

Null-pointer in GUI

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: Windows XP
    • Similar Issues:

      Description

      Hudson ver. 1.111
      Using a Windows system, setting things such as the "Files to archive" as
      "TopUp2.Indosat/TopupAppEAR/target/T*.ear" results in the following error.
      (Also "Test report XMLs" being set to
      "TopUp2.Indosat/*/target/surefire-reports/.xml" does the same.)

      Status Code: 500
      Exception:
      Stacktrace:
      java.lang.NullPointerException
      at hudson.Util.escape(Util.java:375)
      at hudson.util.FormFieldValidator.error(FormFieldValidator.java:68)
      at
      hudson.util.FormFieldValidator$WorkspaceFileMask.check(FormFieldValidator.java:190)
      at hudson.util.FormFieldValidator.process(FormFieldValidator.java:40)
      at hudson.tasks.ArtifactArchiver$DescriptorImpl.doCheck(ArtifactArchiver.java:120)
      at sun.reflect.GeneratedMethodAccessor175.invoke(Unknown Source)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.kohsuke.stapler.Function$InstanceFunction.invoke(Function.java:95)
      at org.kohsuke.stapler.Function.bindAndinvoke(Function.java:51)
      at org.kohsuke.stapler.MetaClass$1.doDispatch(MetaClass.java:63)
      at org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
      at org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      at org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:240)
      at org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
      at org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      at org.kohsuke.stapler.Stapler.invoke(Stapler.java:207)
      at org.kohsuke.stapler.Stapler.service(Stapler.java:72)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:45)
      at winstone.ServletConfiguration.execute(ServletConfiguration.java:249)
      at winstone.RequestDispatcher.forward(RequestDispatcher.java:335)
      at winstone.RequestHandlerThread.processRequest(RequestHandlerThread.java:244)
      at winstone.RequestHandlerThread.run(RequestHandlerThread.java:150)
      at java.lang.Thread.run(Thread.java:619)

      --------------------------------------------------------------------------------
      Generated by Winstone Servlet Engine v0.9.8 at Tue Jun 19 17:19:14 BST 2007

        Attachments

          Issue Links

            Activity

            kohsuke Kohsuke Kawaguchi added a comment -

            I regret I couldn't catch this sooner. It's such an obvious bug.

            Fixed in 1.113.

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 609 has been marked as a duplicate of this issue. ***

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              gwynevans gwynevans
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: