Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-61105

2.204.3 rc fails to open folder in Java 8, throws class not found exception

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: core
    • Environment:
      Jenkins 2.204.3 release candidate as included in my docker-lfs image on the lts-with-plugins-rc branch
      Running Java 8 shows the failure.
      Running Java 11 does not show the failure.
    • Similar Issues:
    • Released As:
      Jenkins 2.227

      Description

      Jenkins 2.204.3 release candidate build fails to open one or more folders in my test docker image when run with Java 8. It reports MethodNotFoundException for a CharBuffer rewind() method. It does not report that error when run with Java 11. Jenkins 2.220 does not report that error. Jenkins 2.204.2 does not report that error.

      The manifest included in the 2.204.3 rc jenkins.war file is:

      Manifest-Version: 1.0
      Build-Jdk-Spec: 11
      Created-By: Maven Archiver 3.4.0
      Hudson-Version: 1.395
      Implementation-Version: 2.204.3-SNAPSHOT
      Jenkins-Version: 2.204.3-SNAPSHOT
      Main-Class: Main
      Remoting-Embedded-Version: 3.36.1
      Remoting-Minimum-Supported-Version: 3.14
      

      The manifest included in the 2.204.2 jenkins.war file is:

      Manifest-Version: 1.0
      Build-Jdk-Spec: 1.8
      Created-By: Maven Archiver 3.4.0
      Hudson-Version: 1.395
      Implementation-Version: 2.204.2
      Jenkins-Version: 2.204.2
      Main-Class: Main
      Remoting-Embedded-Version: 3.36.1
      Remoting-Minimum-Supported-Version: 3.14
      

      Notice the difference in Build-Jdk-Spec.

      See the google groups message for the detailed analysis.

      1. Install git large file support on your Linux computer (or download from git-lfs.github.com)
      2. Iniitalize git lfs with
        $ git lfs install
        Git LFS initialized.
        
      3. Clone my docker-lfs repository
        $ git clone https://github.com/MarkEWaite/docker-lfs
        Cloning into 'docker-lfs'...
        Resolving deltas: 100% (12717/12717), done.
        
      4. Change to the docker-lfs directory
        $ cd docker-lfs
        
      5. Checkout the lts-with-plugins-rc branch
        $ git checkout -b lts-with-plugins-rc -t origin/lts-with-plugins-rc
        Filtering content: 100% (190/190), 244.87 MiB | 5.36 MiB/s, done.
        Branch 'lts-with-plugins-rc' set up to track remote branch 'lts-with-plugins-rc' from 'origin'.
        Switched to a new branch 'lts-with-plugins-rc'
        
      6. Build the docker image
        $ docker build -f Dockerfile -t markewaite/lts-rc:2.204.3 .
        
      7. Run the docker image
        $ docker run --rm -i -e JENKINS_ADVERTISED_HOSTNAME=`hostname` \
        -e START_QUIET=True -p 8080:8080 -t markewaite/lts-rc:2.204.3
        
      8. Connect to the running image with a web browser
        $ python -m webbrowser http://$(hostname):8080/
        
      9. Open each of the folders at the root of that Jenkins server. One of them will fail to an Oops screen (at least does on the 3 machines where I've tested)

      Some of the folders fail to open when I click them and I receive the following stack track in an "Oops" page on one instance:

      org.apache.commons.jelly.JellyTagException: jar:file:/var/jenkins_home/war/WEB-INF/lib/jenkins-core-2.204.3-SNAPSHOT.jar!/hudson/model/View/index.jelly:42:43: <st:include> org.apache.commons.jelly.JellyTagException: jar:file:/var/jenkins_home/war/WEB-INF/lib/jenkins-core-2.204.3-SNAPSHOT.jar!/lib/hudson/projectView.jelly:84:48: <j:forEach> java.nio.CharBuffer.rewind()Ljava/nio/CharBuffer;
      	at org.apache.commons.jelly.impl.TagScript.handleException(TagScript.java:726)
      	at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:281)
      

      In the other test instance, the message appears in the console log and does not appear in the Jenkins Oops page. In the console log, it reports:

      2020-02-15 16:37:04.540+0000 [id=164374]        INFO    j.b.MultiBranchProject$BranchIndexing#run: Bugs-Pipeline-Checks/jenkins-bugs-multibranch-pipeline-bitbucket #20200215.093700 branch indexing action completed: SUCCESS in 3.6 sec
      2020-02-15 16:39:26.329+0000 [id=39]    SEVERE  hudson.triggers.SafeTimerTask#run: Timer task com.cloudbees.jenkins.Cleaner@7ed56677 failed
      java.lang.NoSuchMethodError: java.nio.CharBuffer.rewind()Ljava/nio/CharBuffer;
              at hudson.Util.rawEncode(Util.java:886)
              at hudson.model.AbstractItem.getShortUrl(AbstractItem.java:576)
              at hudson.model.AbstractItem.getUrl(AbstractItem.java:537)
      

      I don't know why there is a difference in behavior. I don't know if the issue is related to something in my local environment, the Docker image definition that I'm using, or something completely different.

      The folders which fail to open are different in the two instances, but the stack traces seem to consistently be associated with CharBuffer.rewind().

      Later in the stack trace, it reports:

      Caused by: java.lang.NoSuchMethodError: java.nio.CharBuffer.rewind()Ljava/nio/CharBuffer;
      	at hudson.Util.rawEncode(Util.java:886)
      

        Attachments

          Activity

          olivergondza Oliver Gondža added a comment -

          Checking back, I have build this RC using openjdk 11.0.6 (unlike all previous ones). This appears to be common problem when built on 9+ and run on older release. The thing is, the return types of some overridden methods in JDK got more specific types than its superclasses have, which is binary-incompatible as the synthetic bridge methods are missing in older JDK runtime.

          I will try to confirm and do a re-spin. Long term fix would be to incorporate[1] so we can safely build on newer JDK while guaranteeing the compatibility for the older one.

          [1] http://openjdk.java.net/jeps/247

          oleg_nenashev Oleg Nenashev added a comment -

          That's strange. We should have all the target JDK flags (--release) in place for Jenkins POMs. So builds by JDK11 should e compatible with JDK8... but apparently they are not.

          We will need to apply patches later, but for now it is better to just builds with JDK8

          olivergondza Oliver Gondža added a comment -

          I have squeezed in some test-ignoring fixes, verified all tests are passing now and will re-publish the RC.

          Oleg Nenashev, this is the exact command that is being run: https://github.com/jenkins-infra/backend-commit-history-parser/blob/aab0dfe7f40c316058ca39eeae148efcddabf5e5/bin/publish-lts-rc#L17. Will have to dig deeper on why it does not pick up the --release flag.

          jglick Jesse Glick added a comment -

          We should have all the target JDK flags (--release) in place for Jenkins POMs.

          I could not find such a flag in jenkinsci/jenkins nor jenkinsci/pom. What is it supposed to look like?

          markewaite Mark Waite added a comment -

          Fixed in the 2.204.3 rc respin that was created on Feb 17, 2020.

          olivergondza Oliver Gondža added a comment -

          Proposing fix for core master branch: https://github.com/jenkinsci/jenkins/pull/4594


            People

            Assignee:
            olivergondza Oliver Gondža
            Reporter:
            markewaite Mark Waite
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: