Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-61236

Cannot use HTTP endpoint and custom port

    XMLWordPrintable

Details

    Description

      The Bitbucket plugin does not appear to retain custom port/protocol configurations for Bitbucket Server. Instead it always defaults back to HTTPS/port 443.

      I am trying to connect to an internally-exposed Kubernetes service endpoint http://bitbucket-svc:7990.

      I can connect to the endpoint at the Manage System configuration page and even when I'm creating my Jenkins pipeline job. However, when I try to build the project, I can see in the logs it's connecting via HTTPS.

      Steps to replicate:

      • Configure the Bitbucket server location to use the default Bitbucket HTTP port 7990.
      • Connect successfully from Manage System and pipeline job configuration
      • Click "Build Now" and observe the protocol/port the plugin tries to connect to

      Attachments

        Activity

          jclem1030 James Clem created issue -
          jclem1030 James Clem made changes -
          Field Original Value New Value
          Description The Bitbucket plugin does not appear to retain custom port/protocol configurations for Bitbucket Server. Instead it always defaults back to HTTPS/port 443. This wouldn't typically be an issue, but I'm using an internal self-signed cert and even though it's been imported into my Java keystore, I still can't seem to connect via that method.

          As a workaround, I am trying to connect to an internally-exposed Kubernetes service endpoint [http://bitbucket-svc:7990.|http://bitbucket-svc:79990.]

          I am able to connect to the endpoint at the Manage System configuration page and even when I'm creating my Jenkins pipeline job. However, when I try to build the project, I can see in the logs it's connecting via HTTPS.

          Steps to replicate:
           * Configure the Bitbucket server location to use the default Bitbucket HTTP port 7990.
           * Connect successfully from Manage System and pipeline job configuration
           * Click "Build Now" and observe the endpoint the plugin tries to connect to
          The Bitbucket plugin does not appear to retain custom port/protocol configurations for Bitbucket Server. Instead it always defaults back to HTTPS/port 443. This wouldn't typically be an issue, but I'm using an internal self-signed cert and even though it's been imported into my Java keystore, I still can't seem to connect via that method (separate issue).

          As a workaround, I am trying to connect to an internally-exposed Kubernetes service endpoint [http://bitbucket-svc:7990.|http://bitbucket-svc:79990.]

          I am able to connect to the endpoint at the Manage System configuration page and even when I'm creating my Jenkins pipeline job. However, when I try to build the project, I can see in the logs it's connecting via HTTPS.

          Steps to replicate:
           * Configure the Bitbucket server location to use the default Bitbucket HTTP port 7990.
           * Connect successfully from Manage System and pipeline job configuration
           * Click "Build Now" and observe the endpoint the plugin tries to connect to
          jclem1030 James Clem made changes -
          Description The Bitbucket plugin does not appear to retain custom port/protocol configurations for Bitbucket Server. Instead it always defaults back to HTTPS/port 443. This wouldn't typically be an issue, but I'm using an internal self-signed cert and even though it's been imported into my Java keystore, I still can't seem to connect via that method (separate issue).

          As a workaround, I am trying to connect to an internally-exposed Kubernetes service endpoint [http://bitbucket-svc:7990.|http://bitbucket-svc:79990.]

          I am able to connect to the endpoint at the Manage System configuration page and even when I'm creating my Jenkins pipeline job. However, when I try to build the project, I can see in the logs it's connecting via HTTPS.

          Steps to replicate:
           * Configure the Bitbucket server location to use the default Bitbucket HTTP port 7990.
           * Connect successfully from Manage System and pipeline job configuration
           * Click "Build Now" and observe the endpoint the plugin tries to connect to
          The Bitbucket plugin does not appear to retain custom port/protocol configurations for Bitbucket Server. Instead it always defaults back to HTTPS/port 443. This wouldn't typically be an issue, but I'm using an internal self-signed cert and even though it's been imported into my Java keystore, I still can't seem to connect via that method (separate issue).

          As a workaround, I am trying to connect to an internally-exposed Kubernetes service endpoint [http://bitbucket-svc:7990.|http://bitbucket-svc:79990.]

          I am able to connect to the endpoint at the Manage System configuration page and even when I'm creating my Jenkins pipeline job. However, when I try to build the project, I can see in the logs it's connecting via HTTPS.

          Steps to replicate:
           * Configure the Bitbucket server location to use the default Bitbucket HTTP port 7990.
           * Connect successfully from Manage System and pipeline job configuration
           * Click "Build Now" and observe the protocol/port the plugin tries to connect to
          jclem1030 James Clem made changes -
          Description The Bitbucket plugin does not appear to retain custom port/protocol configurations for Bitbucket Server. Instead it always defaults back to HTTPS/port 443. This wouldn't typically be an issue, but I'm using an internal self-signed cert and even though it's been imported into my Java keystore, I still can't seem to connect via that method (separate issue).

          As a workaround, I am trying to connect to an internally-exposed Kubernetes service endpoint [http://bitbucket-svc:7990.|http://bitbucket-svc:79990.]

          I am able to connect to the endpoint at the Manage System configuration page and even when I'm creating my Jenkins pipeline job. However, when I try to build the project, I can see in the logs it's connecting via HTTPS.

          Steps to replicate:
           * Configure the Bitbucket server location to use the default Bitbucket HTTP port 7990.
           * Connect successfully from Manage System and pipeline job configuration
           * Click "Build Now" and observe the protocol/port the plugin tries to connect to
          The Bitbucket plugin does not appear to retain custom port/protocol configurations for Bitbucket Server. Instead it always defaults back to HTTPS/port 443.

          I am trying to connect to an internally-exposed Kubernetes service endpoint [http://bitbucket-svc:7990.|http://bitbucket-svc:79990.]

          I am able to connect to the endpoint at the Manage System configuration page and even when I'm creating my Jenkins pipeline job. However, when I try to build the project, I can see in the logs it's connecting via HTTPS.

          Steps to replicate:
           * Configure the Bitbucket server location to use the default Bitbucket HTTP port 7990.
           * Connect successfully from Manage System and pipeline job configuration
           * Click "Build Now" and observe the protocol/port the plugin tries to connect to
          jclem1030 James Clem made changes -
          Description The Bitbucket plugin does not appear to retain custom port/protocol configurations for Bitbucket Server. Instead it always defaults back to HTTPS/port 443.

          I am trying to connect to an internally-exposed Kubernetes service endpoint [http://bitbucket-svc:7990.|http://bitbucket-svc:79990.]

          I am able to connect to the endpoint at the Manage System configuration page and even when I'm creating my Jenkins pipeline job. However, when I try to build the project, I can see in the logs it's connecting via HTTPS.

          Steps to replicate:
           * Configure the Bitbucket server location to use the default Bitbucket HTTP port 7990.
           * Connect successfully from Manage System and pipeline job configuration
           * Click "Build Now" and observe the protocol/port the plugin tries to connect to
          The Bitbucket plugin does not appear to retain custom port/protocol configurations for Bitbucket Server. Instead it always defaults back to HTTPS/port 443.

          I am trying to connect to an internally-exposed Kubernetes service endpoint [http://bitbucket-svc:7990.|http://bitbucket-svc:79990.]

          I can connect to the endpoint at the Manage System configuration page and even when I'm creating my Jenkins pipeline job. However, when I try to build the project, I can see in the logs it's connecting via HTTPS.

          Steps to replicate:
           * Configure the Bitbucket server location to use the default Bitbucket HTTP port 7990.
           * Connect successfully from Manage System and pipeline job configuration
           * Click "Build Now" and observe the protocol/port the plugin tries to connect to
          dkjellin Daniel Kjellin made changes -
          Assignee Kristy Hughes [ khughes ]
          bplump B Plump made changes -
          Labels tracked-by-atlassian
          mhenschke_atlassian Martin Henschke made changes -
          Attachment Screenshot_20200707_163505.png [ 51840 ]
          mhenschke_atlassian Martin Henschke made changes -
          Attachment Screenshot_20200707_163505.png [ 51840 ]
          mhenschke_atlassian Martin Henschke added a comment - - edited

          Hi James, thanks for the report.

          I followed your steps to replicate (using version 1.1.0 of the plugin) and found the correct protocol was being used. I've attached screenshots of the logs.

          Given I was unable to replicate the issue, I will close this for now, but please feel free to reopen if you can find a way to reliably replicate. Thanks,

          Martin 

           

           

          mhenschke_atlassian Martin Henschke added a comment - - edited Hi James, thanks for the report. I followed your steps to replicate (using version 1.1.0 of the plugin) and found the correct protocol was being used. I've attached screenshots of the logs. Given I was unable to replicate the issue, I will close this for now, but please feel free to reopen if you can find a way to reliably replicate. Thanks, Martin     
          mhenschke_atlassian Martin Henschke made changes -
          Attachment Screenshot_20200707_163505.png [ 51841 ]
          mhenschke_atlassian Martin Henschke made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Closed [ 6 ]

          People

            Unassigned Unassigned
            jclem1030 James Clem
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: