Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-61758

Test Result Summary in logs is incorrect.

    XMLWordPrintable

    Details

    • Similar Issues:
    • Released As:
      Latest plug-in version was installed; resolved the issue.

      Description

      I am running a test set via Jenkins with the Micro Focus Application Automation tools plug-in and the syntax 'runFromAlmBuilder'. When the test set completes the summary at the end is incorrect. . I ran a test set that consisted of 51 tests, but when the summary printed at the end it printed the name of the last test that was run 51 times instead of the 51 individual tests that were executed. Below is a snippet from the Jenkins log (you can see the last test is repeated instead of listed each individual test in the summary):

      EntityType=IRun&EntityID=189118\n
      Test: [1]MmRg.00.VITLPOS_SLT-E15_T2, Status: Passed, Message: Test run passed. [host: xx.xxx.xx.xxx] \nLink:
      td://<server name>/qcbin//TestLabModule-000000003649890581?
      EntityType=IRun&EntityID=189084\n
      Test: [1]MmRg.00.VITLPOS_SLT-X8_T2, Status: Passed, Message: Test run passed. [host: xx.xxx.xx.xxx] \nLink:
      td://<server name>/qcbin//TestLabModule-000000003649890581?
      EntityType=IRun&EntityID=189093\n
      Test: [1]MmRg.00.VITLPOS_TABLE-X5_T2, Status: Passed, Message: Test run passed. [host: xx.xxx.xx.xxx] \nLink:
      td://<server name>/qcbin//TestLabModule-000000003649890581?
      EntityType=IRun&EntityID=189087\n
      Test: [1]MmRg.00.VITLPOS_PLUS-X4_T2, Status: Passed, Message: Test run passed. [host: xx.xxx.xx.xxx] \nLink:
      td://<server name>/qcbin//TestLabModule-000000003649890581?
      EntityType=IRun&EntityID=189096\n
      Test set: HWSW Regression, finished at 23/03/2020 14:12:05
      ===========================================
      Run status: Job succeeded, total tests: 51, succeeded: 51, failures: 0, errors: 0
      Passed : Root\Regression\HWSW Regression[1]MmRg.00.VITLPOS_PLUS-X4_T2
      Passed : Root\Regression\HWSW Regression[1]MmRg.00.VITLPOS_PLUS-X4_T2
      Passed : Root\Regression\HWSW Regression[1]MmRg.00.VITLPOS_PLUS-X4_T2
      Passed : Root\Regression\HWSW Regression[1]MmRg.00.VITLPOS_PLUS-X4_T2
      Passed : Root\Regression\HWSW Regression[1]MmRg.00.VITLPOS_PLUS-X4_T2
      Passed : Root\Regression\HWSW Regression[1]MmRg.00.VITLPOS_PLUS-X4_T2
      Passed : Root\Regression\HWSW Regression[1]MmRg.00.VITLPOS_PLUS-X4_T2
      Passed : Root\Regression\HWSW Regression[1]MmRg.00.VITLPOS_PLUS-X4_T2
      Passed : Root\Regression\HWSW Regression[1]MmRg.00.VITLPOS_PLUS-X4_T2
      Passed : Root\Regression\HWSW Regression[1]MmRg.00.VITLPOS_PLUS-X4_T2
      Passed : Root\Regression\HWSW Regression[1]MmRg.00.VITLPOS_PLUS-X4_T2

        Attachments

          Activity

          Hide
          sagerb Barrie Sager added a comment -

          We upgraded to the latest version of the plug-in and that resolved the issue.

          Show
          sagerb Barrie Sager added a comment - We upgraded to the latest version of the plug-in and that resolved the issue.

            People

            Assignee:
            ptofan Paul-Adrian Tofan
            Reporter:
            sagerb Barrie Sager
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: