Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-62038

xcode-integration plugin not compatible with jdk11, complains about jaxb missing

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Duplicate
    • xcode-plugin
    • None
    • java 11 on centos7
      openjdk 11.0.6 2020-01-14 LTS
      OpenJDK Runtime Environment 18.9 (build 11.0.6+10-LTS)
      OpenJDK 64-Bit Server VM 18.9 (build 11.0.6+10-LTS, mixed mode, sharing)

      jenkins 2.222.1

    Description

      21:28:03 Test Suite 'xxxTests' passed at 2020-04-22 21:28:03.142.FATAL: Implementation of JAXB-API has not been found on module path or classpath.21:28:03 Test Suite 'xxx2Tests' started at 2020-04-22 21:28:03.142FATAL: Implementation of JAXB-API has not been found on module path or classpath.21:28:03 2020-04-22 21:28:03.159719+1000 NVivo[92061:44567393] nw_path_close_fd Failed to close guarded necp fd 8 [9: Bad file descriptor]FATAL: Implementation of JAXB-API has not been found on module path or classpath.21:28:06 Build step 'Xcode' marked build as failure

      Attachments

        Issue Links

          Activity

            We still have this issue using Jenkins 2.321, Xcode 13.1 and Xcode plugin 2.0.15 on macOS 11.6.1.

            This is a blocker, can it be fixed quickly, please? Thanks!

            flabrie Francis Labrie added a comment - We still have this issue using Jenkins 2.321, Xcode 13.1 and Xcode plugin 2.0.15 on macOS 11.6.1. This is a blocker, can it be fixed quickly, please? Thanks!

            We still have this issue with:

            • Jenkins 2.346
            • Xcode 13.3.1
            • Java Runtime 11.0.15+0
            • Xcode plugin 2.0.16-SNAPSHOT
            • macOS Monterey 12.3.1

            The error message is:
            FATAL: Implementation of JAXB-API has not been found on module path or classpath.
             

            flabrie Francis Labrie added a comment - We still have this issue with: Jenkins 2.346 Xcode 13.3.1 Java Runtime 11.0.15+0 Xcode plugin 2.0.16-SNAPSHOT macOS Monterey 12.3.1 The error message is: FATAL: Implementation of JAXB-API has not been found on module path or classpath.  
            basil Basil Crow added a comment -

            flabrie This is an open source project, so pull requests are welcome. If you are not able to submit a pull request, the least you could do is provide steps to reproduce the issue from scratch on a clean installation.

            basil Basil Crow added a comment - flabrie This is an open source project, so pull requests are welcome. If you are not able to submit a pull request, the least you could do is provide steps to reproduce the issue from scratch on a clean installation.
            markewaite Mark Waite added a comment -

            Closing as a duplicate of JENKINS-64917

            markewaite Mark Waite added a comment - Closing as a duplicate of JENKINS-64917

            People

              Unassigned Unassigned
              mkwan mee kwan
              Votes:
              5 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: