Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-62763

SVN_REVISION or SVN_URL variables not defined

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      Windows Server 2016
      Jenkins 2.222.4
      Subversion Plug-in version 2.13.1
    • Similar Issues:

      Description

      I have several multibranch pipeline jobs that have used the subversion plug-in and the environment variables SVN_URL and SVN_REVISION have always been defined.  These are all single module checked out configurations.  I have a few jobs where the variable is defined but for most the variable is not defined.  I am not sure of the difference since they all use the same configuration and Jenkinsfile.

        Attachments

          Activity

          marioja Mario Jauvin added a comment -

          One difference I have noted is that the svn url where the variables are not found contains lower/upper case characters.  This used to work in previous version of the subversion plug-in.  I do not recall which version.

          marioja Mario Jauvin added a comment -

          The other difference I see is that the repository base URL is longer in the cases where the variables are not defined

          marioja Mario Jauvin added a comment -

          I was trying to troubleshoot and I made the URL same length with no uppercases.  Same problem.  Made URL shorter (sort of normal length). Same problem.  I reverted to original URL and the problem disappeared!  The SVN_URL and SVN_REVISION appeared.  What can be the cause of this behaviour?  Is there some caching done somewhere?  In the past, I had tried to remove the job from Jenkins and recreated it and the problem was still there.  One last note to point, I have been using JOB DSL to create those jobs.  Don't know if that is a factor.

          Last but not least, since this was unassigned from someone a few minutes after creating, will anyone look into this?

          marioja Mario Jauvin added a comment - - edited

          Update, I recreated the job using job DSL and I get the error again using the same repository base url.  I still get the error if I delete the job and recreate it manually, even using a different name.  The job is created inside a folder if that is something that matters.

          marioja Mario Jauvin added a comment -

          I found out what was going on.  I had two consecutive / in the repository base URL.  Once I removed it, everything works.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            marioja Mario Jauvin
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: