Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-62776

NoClassDefFoundErrors after updating

    XMLWordPrintable

Details

    • 1.11

    Description

      After updating to latest Jenkins and artifact-manager-s3, I see an unreadable message for pretty much every single build on the manage old data page:

      NoClassDefFoundError: com/google/common/base/Supplier, ConversionException: Could not call io.jenkins.plugins.artifact_manager_jclouds.JCloudsArtifactManager.readResolve() : Missing provider field : Could not call io.jenkins.plugins.artifact_manager_jclouds.JCloudsArtifactManager.readResolve() : Missing provider field ---- Debugging information ---- message : Could not call io.jenkins.plugins.artifact_manager_jclouds.JCloudsArtifactManager.readResolve() : Missing provider field cause-exception : com.thoughtworks.xstream.converters.reflection.ObjectAccessException cause-message : Could not call io.jenkins.plugins.artifact_manager_jclouds.JCloudsArtifactManager.readResolve() : Missing provider field class : io.jenkins.plugins.artifact_manager_jclouds.JCloudsArtifactManager required-type : io.jenkins.plugins.artifact_manager_jclouds.JCloudsArtifactManager converter-type : hudson.util.RobustReflectionConverter path : /flow-build/artifactManager line number : 792 -------------------------------

      Additionally, attempting to validate the s3 bucket configuration on the settings page gets me a "NoClassDefFoundError:com/google/common/collect/Sets"

       

      This is obviously breaking the ability to fetch artifacts from old builds, and new builds are dumping their artifacts right on the local file system rather than going to S3.

      Attachments

        Issue Links

          Activity

            baf Robert Ferris created issue -
            baf Robert Ferris added a comment -

            Also, downgrading to 1.9 makes the problem go away.

            baf Robert Ferris added a comment - Also, downgrading to 1.9 makes the problem go away.
            mwos Michał Woś added a comment -

            +1

            Also reloading configuration-as-code dies because of the same problem. And yes, downgrading to 1.9 does the job.

            mwos Michał Woś added a comment - +1 Also reloading configuration-as-code dies because of the same problem. And yes, downgrading to 1.9 does the job.
            mwos Michał Woś made changes -
            Field Original Value New Value
            Priority Major [ 3 ] Critical [ 2 ]
            spenser309 Spenser Gilliland made changes -

            +1 looks like this in the configuration screen after you click validate bucket 

             

            spenser309 Spenser Gilliland added a comment - +1 looks like this in the configuration screen after you click validate bucket   
            timja Tim Jacomb added a comment -

            cc jglick

            timja Tim Jacomb added a comment - cc jglick
            jglick Jesse Glick made changes -
            Assignee Jesse Glick [ jglick ]
            jglick Jesse Glick added a comment -

            git bisect confirms that https://github.com/jenkinsci/artifact-manager-s3-plugin/pull/122 caused the plugin to no longer bundle a special version of Guava.

            jglick Jesse Glick added a comment - git bisect confirms that https://github.com/jenkinsci/artifact-manager-s3-plugin/pull/122 caused the plugin to no longer bundle a special version of Guava.
            jglick Jesse Glick made changes -
            Link This issue is caused by JENKINS-41827 [ JENKINS-41827 ]
            jglick Jesse Glick added a comment -

            Without JENKINS-41827 it is hard to have automated tests catch this sort of thing, unfortunately.

            jglick Jesse Glick added a comment - Without JENKINS-41827 it is hard to have automated tests catch this sort of thing, unfortunately.
            jglick Jesse Glick made changes -
            Labels regression
            jglick Jesse Glick made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            jglick Jesse Glick made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            jglick Jesse Glick made changes -
            Remote Link This issue links to "artifact-manager-s3 #140 (Web Link)" [ 25236 ]
            jglick Jesse Glick made changes -
            Released As 1.11
            Resolution Fixed [ 1 ]
            Status In Review [ 10005 ] Fixed but Unreleased [ 10203 ]
            jglick Jesse Glick added a comment -

            Sorry for the disruption!

            jglick Jesse Glick added a comment - Sorry for the disruption!
            jglick Jesse Glick made changes -
            Status Fixed but Unreleased [ 10203 ] Resolved [ 5 ]
            jglick Jesse Glick made changes -
            Link This issue relates to JENKINS-66984 [ JENKINS-66984 ]

            People

              jglick Jesse Glick
              baf Robert Ferris
              Votes:
              1 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: