Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-628

Upgrading from 1.113 to 1.114 loses build history

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: other
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Attempts to upgrade from version 1.113 to 1.114 of Hudson loses the project
      history for two of my projects, but one seems to be working. The two projects in
      question use the Trac plugin, but are otherwise the same as the one whose
      project status seems intact. I also tried 1.115 with the same results.

      Downgrading Hudson to 1.113 restores the build history. So I will remain at that
      version until the problem is identified. This saddens me because I really like
      the new storm clouds in the job list.

        Attachments

          Activity

          thorinside thorinside added a comment -

          Created an attachment (id=69)
          Tomcat 5.5 Logs after 1.116-SNAPSHOT release tests.

          thorinside thorinside added a comment -

          Unfortunately, it seems I am still getting much the same behaviour from the
          1.116-SNAPSHOT release I just tried out, which was dated 7pm last night. All of
          my old build history is gone (due to the reading errors). I've uploaded the new
          logs.

          kohsuke Kohsuke Kawaguchi added a comment -

          There was a problem in my production Hudson system last night, and snapshot
          delivery has been stopped.

          Please try 1.116 that I just released. I really think the problem is fixed now.

          thorinside thorinside added a comment -

          Okay, I will do that very shortly and verify it works. Thanks.

          thorinside thorinside added a comment -

          I have verified this fix is working on our server. Thanks very much. The version
          number of the snapshot I tried was: Hudson ver. 1.117-SNAPSHOT
          (private-07/11/2007 04:36-hudson)


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            thorinside thorinside
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: