Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-62987

Wrong information about UTF-8 url decoding

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Component/s: core
    • Labels:
      None
    • Environment:
      WebSphere Liberty Profile or OpenLiberty, any version
    • Similar Issues:

      Description

      Problem description

      Jenkins displays this banner in the settings:

      Ihr Servlet-Container verwendet kein UTF-8, um URLs zu dekodieren. Falls Sie Nicht-ASCII-Zeichen in Elementnamen usw. verwenden, kann dies Probleme mit sich bringen. Beachten Sie bitte die Hinweise zu Servlet-Containern bzw. Tomcat i18N).

      However, this is not true. Liberty Profile uses UTF-8 by default for decoding URIs.

      Sources:

       

      How to reproduce

      1. use ./bin/server create jenkins to create a new serer.
      2. Download the jenkins .war file to the apps directory of the server ($WLP_INSTALL_DIR/usr/servers/jenkins/apps).
      3. Modify the server.xml to contain these config items:
      <featureManager>
       <feature>servlet-4.0</feature>
       <feature>websocket-1.1</feature>
       <feature>localConnector-1.0</feature>
       <feature>jaxb-2.2</feature>
       <feature>jaxws-2.2</feature>
      </featureManager>
      
      <httpEndpoint id="defaultHttpEndpoint" host="*" httpPort="8080" httpsPort="-1" />
      <application id="jenkins" location="jenkins.war" name="jenkins" type="war" context-root="/" />
      
      1. Modify the file server.env to contain a JENKINS_HOME
      2. Start Liberty Profile (./bin/server start jenkins)

      Go to the settings and see the misleading banner

      Expected behaviour

      Jenkins does not display this banner, as OpenLiberty uses UTF-8 to decode URLs.

      Actual behaviour

      Jenkins does display this banner, which is misleading.

      Suggested fix

      Rework the URL check to display a proper message and how it got this information.

       

      I guess the issue might be related to my reverse proxy, which is set up in front of liberty profile. But as the message does not display why jenkins thinks the container is set up in a wrong way, I cannot confirm this behaviour.

       

       

        Attachments

          Activity

          bmarwell Ben M added a comment -

          Daniel Beck please close this, I created  this issue: https://github.com/jenkins-infra/jenkins.io/issues/3645

          Please kindly take a look at the JDK 11 issue I linked. I do not know why such a blocker gets no attention

          danielbeck Daniel Beck added a comment -

          I do not know why such a blocker gets no attention

          In case that's not rhetorical: Based on our usage stats, just over 0.1% of Jenkins instances are running on JDK 11, despite us having multiple supported Docker images with that. Guess how many of those instances are also on Liberty. I would not be surprised to learn that you're the only one running Jenkins that way.

          bmarwell Ben M added a comment -

          The referenced issue will result in an error on most application servers and affects all java versions since 9+.

          You can close this issue now, if you like.

          danielbeck Daniel Beck added a comment -

          Ben M Thanks for the clarification.

          bmarwell Ben M added a comment -

          Wiki was updated.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            bmarwell Ben M
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: