Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6323

Hudson backup unable to read filesystem attributes for gif.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: backup-plugin
    • Labels:
      None
    • Environment:
      Linux fldbuild02 2.6.27.21-78.2.41.fc9.x86_64 #1 SMP Mon Mar 23 23:22:15 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
      Hudson 1.355; backup plugin 1.4.1
    • Similar Issues:

      Description

      Hudson wasn't generating the backup file. The permissions on /var/hudson/ didn't allow writes. Hudson/Backup Plugin didn't provide any notice of this, nor did it cancel the operation. Before I noticed the permissions were wrong I tried to add a comment to http://issues.jenkins-ci.org/browse/JENKINS-5669, and cloned the bug expecting an option to append text. I Fail'd it. http://issues.jenkins-ci.org/browse/JENKINS-6320 can be closed.

      The next problem:

      [ INFO] Backup started at [04/20/10 22:40:06] [ INFO] Setting hudson in shutdown mode to avoid files corruptions. [ INFO] Waiting all jobs end... [ INFO] Number of running jobs detected : 0
      [ INFO] All jobs finished. [ INFO] Full backup file name : /var/hudson/backup_20100420_2240.tar.bz2
      [ERROR] org.codehaus.plexus.archiver.ArchiverException: Failed to read filesystem attributes for: /home/fldbuild/.hudson/war/images/16x16/red_anime.gif org.jvnet.hudson.plugins.backup.BackupException: java.io.IOException: Unable to add war/images/16x16/red_anime.gif at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:115) at org.jvnet.hudson.plugins.backup.utils.BackupTask.run(BackupTask.java:125) at java.lang.Thread.run(Thread.java:619) Caused by: java.io.IOException: Unable to add war/images/16x16/red_anime.gif at org.jvnet.hudson.plugins.backup.utils.BackupEngine.handleFile(BackupEngine.java:90) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:367) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:335) at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:113) ... 2 more [ INFO] Cancel hudson shutdown mode [ INFO] Backup end at [04/20/10 22:40:56] [ INFO] [49.631s]

        Attachments

          Activity

          mrobinet mrobinet added a comment -

          Duplicate of JENKINS-6070.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            cahylles cahylles
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: