Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-63446

Many fails during a deployment Virtual Machine Scale Sets

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: _unsorted
    • Labels:
      None
    • Similar Issues:

      Description

      Issue :

       

      VM provisioning failed with timeout error , passed in second try or more .

      Attached deployment error log from the portal 

      Attached AzureCloudException from jenkins + jenkins log.

       

       

       

        Attachments

          Activity

          emoataz Moataz Eisa added a comment -

          Any update ?

          emoataz Moataz Eisa added a comment -

          Any update ?

          azure_devops Azure DevOps added a comment -

          We will take a look at this issue. Please expect xu zhang to share any possible updates in the next couple of days.

           

          zooopx xu zhang added a comment -

          Hi Moataz Eisa From the log your attached, I found two types of errors:

          1. Provision new Jenkins VM failed.
          2. Clean task failed,  this error can be ignored,  `AzureVMAgentCleanUpTask ` failure won't stop the Jenkins VM instance and task execution. 

          Both are caused by network connection timeout. I have checked the AzureClient we are using and the default timeout is set to 10 seconds. Can you help check the network latency from your Jenkins environment to Azure and if your Jenkins network environment is stable?

          I try provision new Jenkins VM instance from my local dev machine or Azure machine, all worked for me.   

           

           

          timja Tim Jacomb added a comment -

          All issues have been transferred to GitHub.

          See https://github.com/jenkinsci/azure-vm-agents-plugin/issues

          Search the issue title to find it.

          (This is a bulk comment and can't link to the specific issue)


            People

            Assignee:
            azure_devops Azure DevOps
            Reporter:
            emoataz Moataz Eisa
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: