Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-636

Default domain incorrectly appended to username

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      ERROR: Illegal character in domain
      javax.mail.internet.AddressException: Illegal character in domain in string
      This happens when the username is already a valid email

      ``heiko.braun@jboss.com@jboss.com''
      at javax.mail.internet.InternetAddress.checkAddress(InternetAddress.java:933)
      at javax.mail.internet.InternetAddress.parse(InternetAddress.java:819)
      at javax.mail.internet.InternetAddress.parse(InternetAddress.java:555)
      at javax.mail.internet.InternetAddress.<init>(InternetAddress.java:91)
      at hudson.tasks.MailSender.createEmptyMail(MailSender.java:252)
      at hudson.tasks.MailSender.createFailureMail(MailSender.java:143)
      at hudson.tasks.MailSender.getMail(MailSender.java:87)
      at hudson.tasks.MailSender.execute(MailSender.java:64)
      at hudson.tasks.Mailer.perform(Mailer.java:61)

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          Fixed in 1.118.

          kohsuke Kohsuke Kawaguchi added a comment -
              • Issue 630 has been marked as a duplicate of this issue. ***

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            tdiesler Thomas Diesler
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: