Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-63670

Confusing warning about PostgreSQL version

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Fixed but Unreleased (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: pipeline-maven-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.249.1
      org.jenkins-ci.main:maven-plugin:3.7
    • Similar Issues:
    • Released As:
      pipeline-maven-plugin 3.11.0

      Description

      I followed the "Using a PostgreSQL database" guide on https://plugins.jenkins.io/pipeline-maven/ to replace my current H2 database. It seems that everything is set up properly, but still I get a warning

      Non tested PostgreSQL version 12.2. MySQL Server version 5.7+ or Amazon Aurora MySQL 5.6+ or MariaDB 10.2+ or PostgreSQL 10+ is required

      I indeed have PostgreSQL version 12.2, so why is Jenkins complaining and telling me PostgreSQL 10+ is required? Isn't 12.2 more than 10?

      > psql --version
      psql (PostgreSQL) 12.2
      

       

      Here a screenshot of my current configuration:

        Attachments

          Issue Links

            Activity

            Hide
            aheritier Arnaud Héritier added a comment -

            no sorry Robin JansohnI didn't have the time to do some tests.

            I will try to do some this month (but not promised - I have already a lot of things to do on my personal time)

            Show
            aheritier Arnaud Héritier added a comment - no sorry Robin Jansohn I didn't have the time to do some tests. I will try to do some this month (but not promised - I have already a lot of things to do on my personal time)
            Hide
            hadjiyski Robert Hadjiyski added a comment -

            Hi Arnaud Héritier, same here:

            Non tested PostgreSQL version 13.1. MySQL Server version 5.7+ or Amazon Aurora MySQL 5.6+ or MariaDB 10.2+ or PostgreSQL 10+ is required
            could you please check. Thx.

            Show
            hadjiyski Robert Hadjiyski added a comment - Hi Arnaud Héritier , same here: Non tested PostgreSQL version 13.1. MySQL Server version 5.7+ or Amazon Aurora MySQL 5.6+ or MariaDB 10.2+ or PostgreSQL 10+ is required could you please check. Thx.
            Hide
            jpara29 PJ added a comment -

            Hello Arnaud Héritier

            Could you please let me know if these tests are completed and are good to go for PostGreSQL 12+ ? We are planning to upgrade to higher Postgresql version (from 11.3) and wanted to know if moving to 12/13 would help or not.

            Show
            jpara29 PJ added a comment - Hello Arnaud Héritier Could you please let me know if these tests are completed and are good to go for PostGreSQL 12+ ? We are planning to upgrade to higher Postgresql version (from 11.3) and wanted to know if moving to 12/13 would help or not.
            Hide
            aheritier Arnaud Héritier added a comment -

            Sadly it is still on my too long todo list.

            What I would like is to automate these tests to be sure that we cover a good number of DBs/Versions ...

            Show
            aheritier Arnaud Héritier added a comment - Sadly it is still on my too long todo list. What I would like is to automate these tests to be sure that we cover a good number of DBs/Versions ...
            Hide
            bguerin Benoit added a comment -

            Hello,

            I am using this plugin on production for one year now, at the begin with a PostgreSQL 12, then upgraded to a 13, without any issue.
            You can safely ignore the warning and use a PostgreSQL 13

            I will send a quick fix pull request to avoid this warning with PostgreSQL up to 13. We will add tests later.

            Show
            bguerin Benoit added a comment - Hello, I am using this plugin on production for one year now, at the begin with a PostgreSQL 12, then upgraded to a 13, without any issue. You can safely ignore the warning and use a PostgreSQL 13 I will send a quick fix pull request to avoid this warning with PostgreSQL up to 13. We will add tests later.

              People

              Assignee:
              bguerin Benoit
              Reporter:
              dokaspar Dominik Kaspar
              Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: