Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-63694

UTFDataFormatException thrown while recording issues.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: analysis-model
    • Labels:
      None
    • Environment:
      Jenkins 2.249.1
      Warnings NG Plugin 8.4.2
      Ubuntu 16.04 x86_64 (Jenkins Server)
      Mac OS X (Jenkins Agent)
    • Similar Issues:

      Description

      When recording GCC issues, a UTFDataFormatException exception is thrown with the following stack trace:

       [GNU C Compiler (gcc)] Sleeping for 5 seconds due to JENKINS-32191...
       [GNU C Compiler (gcc)] Parsing console log (workspace: '/Users/build/workspace/software_release_3.1.x')
       [GNU C Compiler (gcc)] Successfully parsed console log
       [GNU C Compiler (gcc)] -> found 2327 issues (skipped 1235 duplicates)
       java.io.UTFDataFormatException
       	at java.io.ObjectOutputStream$BlockDataOutputStream.writeUTF(ObjectOutputStream.java:2164)
       	at java.io.ObjectOutputStream$BlockDataOutputStream.writeUTF(ObjectOutputStream.java:2007)
       	at java.io.ObjectOutputStream.writeUTF(ObjectOutputStream.java:869)
       	at edu.hm.hafner.analysis.Report.writeIssues(Report.java:827)
       	at edu.hm.hafner.analysis.Report.writeObject(Report.java:802)
       	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
       	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
       	at java.lang.reflect.Method.invoke(Method.java:498)
       	at java.io.ObjectStreamClass.invokeWriteObject(ObjectStreamClass.java:1140)
       	at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1496)
       	at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1432)
       	at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1178)
       	at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1548)
       	at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1509)
       	at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1432)
       	at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1178)
       	at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1548)
       	at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1509)
       	at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1432)
       	at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1178)
       	at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:348)
       	at hudson.remoting.UserRequest._serialize(UserRequest.java:263)
       	at hudson.remoting.UserRequest.serialize(UserRequest.java:272)
       	at hudson.remoting.UserRequest.<init>(UserRequest.java:101)
       	at hudson.remoting.Channel.call(Channel.java:999)
       	at hudson.FilePath.act(FilePath.java:1070)
       	at hudson.FilePath.act(FilePath.java:1059)
       	at io.jenkins.plugins.analysis.core.steps.IssuesScanner.postProcessReport(IssuesScanner.java:114)
       	at io.jenkins.plugins.analysis.core.steps.IssuesScanner.scan(IssuesScanner.java:104)
       	at io.jenkins.plugins.analysis.core.steps.IssuesRecorder.scanWithTool(IssuesRecorder.java:681)
       	at io.jenkins.plugins.analysis.core.steps.IssuesRecorder.record(IssuesRecorder.java:646)
       	at io.jenkins.plugins.analysis.core.steps.IssuesRecorder.perform(IssuesRecorder.java:617)
       	at io.jenkins.plugins.analysis.core.steps.RecordIssuesStep$Execution.run(RecordIssuesStep.java:1024)
       	at io.jenkins.plugins.analysis.core.steps.RecordIssuesStep$Execution.run(RecordIssuesStep.java:985)
       	at org.jenkinsci.plugins.workflow.steps.SynchronousNonBlockingStepExecution.lambda$start$0(SynchronousNonBlockingStepExecution.java:47)
       	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
       	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
       	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
       	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
       	at java.lang.Thread.run(Thread.java:748)
       Finished: FAILURE
      

        Attachments

          Activity

          mdelaney Mike Delaney added a comment - - edited

          Downgrading to 8.4.1 appears to be a valid work around.

          I thought this was true, but after a few builds the issue came back.

          drulli Ulli Hafner added a comment -

          Do you still have analysis model 9.0.0 installed after the downgrade? Can you open the issues details for old builds?

          drulli Ulli Hafner added a comment -

          Is one of your messages very long? (i.e. > 65536 characters?)

          mdelaney Mike Delaney added a comment -

          Ulli Hafner, yes, I still have Analysis Model API Plugin v9.0.0 installed.

          I did a quick spot check, and I found a line with 52_853 characters but nothing that broke the 65_636 character limit.

          mdelaney Mike Delaney added a comment -

          Ulli Hafner, I ran nokogiri over the gcc-outstanding-issues.xml file and the longest string I found was 53_216.

          drulli Ulli Hafner added a comment -

          Ok, maybe the limit of 64_000 actually was wrong. I created a test case with 100_000 characters and can now reproduce the bug. Fix is submitted.

          drulli Ulli Hafner added a comment -

          Yes, since the bug is in analysis model 9.0.0 it will not help to downgrade to 8.4.1.

          But 9.0.1 is released and should fix the problem.


            People

            Assignee:
            drulli Ulli Hafner
            Reporter:
            mdelaney Mike Delaney
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: