Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-63718

Unreadable data for Folder plugin after 2.249.1 upgrade

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Duplicate
    • None
    • Jenkins 2.235.5 (attempting to upgrade to 2.249.1)
      Java 1.8.0.252
      Folder plugin 6.14

    Description

      If I upgrade our Jenkins instance from 2.235.5 to the new stable 2.249.1 release, I get warnings about unreadable data for the Folder plugin after it comes back up. Our various folders then have no content; attempting to navigate into them gives an error (I think it was a 404).

      Here is the complaint about the Folder plugin data, issued once for each folder:

      com.cloudbees.hudson.plugins.folder.Folder	
      
      ConversionException: Could not call hudson.model.ListView.readResolve() : null
      
      ---- Debugging information ----
      message : Could not call hudson.model.ListView.readResolve() : null
      cause-exception : com.thoughtworks.xstream.converters.reflection.ObjectAccessException
      cause-message : Could not call hudson.model.ListView.readResolve() : null
      class : hudson.model.ListView
      required-type : hudson.model.ListView
      converter-type : hudson.util.RobustReflectionConverter
      path : /com.cloudbees.hudson.plugins.folder.Folder/folderViews/views/hudson.model.ListView
      line number : 34
      -------------------------------
      

      I have tried the upgrade a couple of times, in case it was some kind of transient issue, but it failed in exactly the same way both times.

      (Fortunately, downgrading back to 2.235.5 gets everything back to normal.)

      Attachments

        Issue Links

          Activity

            markewaite Mark Waite added a comment - - edited

            Does the folder config.xml file include a statusFilter XML tag? JENKINS-62661 notes that views defined with statusFilter do not upgrade from Jenkins 2.235.5 to Jenkins 2.249.1. There is a data migration missing.

            I confirmed that when a view defined on a folder in Jenkins 2.235.5 includes a status filter (for example, "Enabled Jobs only"), that view is lost when upgrading to Jenkins 2.249.1. I had 3 views in a folder in Jenkins 2.235.5. I added a status filter "Enabled Jobs only" in Jenkins 2.235.5 to 2 of the views. When I upgraded to 2.249.1, the 2 views were deleted, leaving only 1 view in the folder.

            markewaite Mark Waite added a comment - - edited Does the folder config.xml file include a statusFilter XML tag? JENKINS-62661 notes that views defined with statusFilter do not upgrade from Jenkins 2.235.5 to Jenkins 2.249.1. There is a data migration missing. I confirmed that when a view defined on a folder in Jenkins 2.235.5 includes a status filter (for example, "Enabled Jobs only"), that view is lost when upgrading to Jenkins 2.249.1. I had 3 views in a folder in Jenkins 2.235.5. I added a status filter "Enabled Jobs only" in Jenkins 2.235.5 to 2 of the views. When I upgraded to 2.249.1, the 2 views were deleted, leaving only 1 view in the folder.
            mparry Morgan Parry added a comment -

            I think that is the same issue, yes. I did search, but I think that other issue lacks the keyword 'unreadable'! Feel free to close this as a duplicate.

            mparry Morgan Parry added a comment - I think that is the same issue, yes. I did search, but I think that other issue lacks the keyword 'unreadable'! Feel free to close this as a duplicate.
            markewaite Mark Waite added a comment -

            Thanks. Jenkins 2.258 is being built now with a proposed fix. We'll also be proposing a backport of the fix into Jenkins 2.249.2 LTS. We'd love to have additional verification that the problem is resolved in Jenkins 2.258 (once it is released today)

            markewaite Mark Waite added a comment - Thanks. Jenkins 2.258 is being built now with a proposed fix. We'll also be proposing a backport of the fix into Jenkins 2.249.2 LTS. We'd love to have additional verification that the problem is resolved in Jenkins 2.258 (once it is released today)
            mparry Morgan Parry added a comment -

            I can't help with that but I can confirm that removing the statusFilter settings fixed the upgrade.

            mparry Morgan Parry added a comment - I can't help with that but I can confirm that removing the statusFilter settings fixed the upgrade.

            People

              fcojfernandez Francisco Fernández
              mparry Morgan Parry
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: