Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-63749

RequestorRecipientProvider returns wrong user when rebuild plugin is used

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Labels:
      None
    • Environment:
      Jenkins ver: 2.257
      email-ext-plugin: 2.76
      rebuild-plugin: 1.31
    • Similar Issues:

      Description

      When using the rebuild plugin and configuring email notifications to use the RequestorRecipientProvider, the email-ext plugin will email the original upstream build requestor and not the user who requested the rebuild.

      As far as I can see, there is a corresponding change that was merged, but not included in the release:

      https://issues.jenkins-ci.org/browse/JENKINS-61380

      Is it possible to add this to the official release?

       

       

       

       

        Attachments

          Activity

          slide_o_mix Alex Earl added a comment -

          It has been release.

          bogdan_pedchenko Bogdan Pedchenko added a comment -

          Hi Alex Earl,

          Thanks for your answer, but this problem is reproducible on these versions of the environment (as far as I know on older ones, this problem is also present):

          Jenkins ver: 2.257
          email-ext-plugin: 2.76
          rebuild-plugin: 1.31

          Could you please indicate the version on which this problem is exactly solved and released?

           

           

          slide_o_mix Alex Earl added a comment -

          There have been multiple releases since then, so I don't know which one specifically had the fix.


            People

            Assignee:
            slide_o_mix Alex Earl
            Reporter:
            bogdan_pedchenko Bogdan Pedchenko
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: